Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Is /clock being published?

Hi Guys,

This question has been asked before, however I was not able to fix the issue by using the recommended solutions. Kindly help me in understanding the reason for this prompt and also the steps to fix the issue. Details given below.

I am using Apollo Auto (open source autonomous car project) which uses ros platform for communication between the nodes. Basically Apollo uses docker environment to run the project.

I want to publish some messages from my host system (that is outside the docker) and subscribe the published messages in Apollo (inside the docker).

As an initial step, I have just published a simple message using rostopic pub -r 10 /my_topic std_msgs/String "my topic is published". It was successfully published however when I run rostopic echo /my_topic inside the docker it is giving prompt as below and I am not able to see the messages. user@in_dev_docker:/apollo$ rostopic echo /my_topic WARNING: no messages received and simulated time is active. Is /clock being published?

As suggested in one of the post, I have tried changing the rosparam use_sim_time to false. But I am still not able to see any published messages.

user@in_dev_docker:/apollo$ rostopic echo /my_topic /use_sim_time is not set, will not subscribe to simulated time [/clock] topic

Could you please help me to fix this so that I can see the messages inside the docker.

Thank you, KK

Is /clock being published?

Hi Guys,

This question has been asked before, however I was not able to fix the issue by using the recommended solutions. Kindly help me in understanding the reason for this prompt and also the steps to fix the issue. Details given below.

I am using Apollo Auto (open source autonomous car project) which uses ros platform for communication between the nodes. Basically Apollo uses docker environment to run the project.

I want to publish some messages from my host system (that is outside the docker) and subscribe the published messages in Apollo (inside the docker).

As an initial step, I have just published a simple message using rostopic pub -r 10 /my_topic std_msgs/String "my topic is published". It was successfully published however when I run rostopic echo /my_topic inside the docker it is giving prompt as below and I am not able to see the messages. user@in_dev_docker:/apollo$ rostopic echo /my_topic WARNING: no messages received and simulated time is active. Is /clock being published?

As suggested in one of the post, I have tried changing the rosparam use_sim_time to false. But I am still not able to see any published messages.

user@in_dev_docker:/apollo$ rostopic echo /my_topic /use_sim_time is not set, will not subscribe to simulated time [/clock] topic

Could you please help me to fix this so that I can see the messages inside the docker.

Thank you, KK

click to hide/show revision 3
retagged

Is /clock being published?

Hi Guys,

This question has been asked before, however I was not able to fix the issue by using the recommended solutions. Kindly help me in understanding the reason for this prompt and also the steps to fix the issue. Details given below.

I am using Apollo Auto (open source autonomous car project) which uses ros platform for communication between the nodes. Basically Apollo uses docker environment to run the project.

I want to publish some messages from my host system (that is outside the docker) and subscribe the published messages in Apollo (inside the docker).

As an initial step, I have just published a simple message using rostopic pub -r 10 /my_topic std_msgs/String "my topic is published". It was successfully published however when I run rostopic echo /my_topic inside the docker it is giving prompt as below and I am not able to see the messages. user@in_dev_docker:/apollo$ rostopic echo /my_topic WARNING: no messages received and simulated time is active. Is /clock being published?

As suggested in one of the post, I have tried changing the rosparam use_sim_time to false. But I am still not able to see any published messages.

user@in_dev_docker:/apollo$ rostopic echo /my_topic /use_sim_time is not set, will not subscribe to simulated time [/clock] topic

Could you please help me to fix this so that I can see the messages inside the docker.

Thank you, KK