Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

nvidia-docker2 tutorial fails even when following exact steps

I am following this tutorial. After running run_my_image.sh from the tutorials, this is the output:

xauth:  /tmp/.docker.xauth not writable, changes will be ignored
xauth: (argv):1:  unable to read any entries from file "(stdin)"
chmod: changing permissions of '/tmp/.docker.xauth': Operation not permitted

then inside the docker interactive terminal, after running rosrun rviz rviz here is the output:

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
qt.qpa.screen: QXcbConnection: Could not connect to display 
Could not connect to any X display.

my $DISPLAY = :1

after looking at this post, I did try to add xhost +si:localuser:root at the beginning of my run_my_image.sh file, yet the error still showed up. I also tried xhost +"local:docker@"; but still same resoponse.

I am running docker without sudo, but docker has been added to the sudo user group.

I also tried sudo ./run_my_image.sh and this is the output from the host terminal:

xauth: (argv):1: unable to read any entries from file "(stdin)" non-network local connections being added to access control list

yet the display error inside docker terminal does not change. Its the same as above.

my docker version is 18.06.1-ce but I did try 18.09, yet uninstalled it and reverted back when I realized that the update didn't change anything.

My system is ubuntu 18.04 Bionic.