Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

No module named "yaml"

I installed ROS on Ubuntu 11.10 using the complete desktop install from ros.org. However, when I try to run roscore, I get the following error:

Traceback (most recent call last):

File "/opt/ros/electric/ros/bin/roscore", line 34, in <module> from ros import roslaunch File "/opt/ros/electric/ros/core/roslib/src/ros/__init__.py", line 57, in __getattr__ return __import__(name) File "/opt/ros/electric/stacks/ros_comm/tools/roslaunch/src/roslaunch/__init__.py", line 43, in <module> import roslaunch.param_dump File "/opt/ros/electric/stacks/ros_comm/tools/roslaunch/src/roslaunch/param_dump.py", line 43, in <module> import yaml ImportError: No module named yaml

I found someone with the same problem here: http://answers.ros.org/question/12862/nao-error-no-module-named-yaml

I also tried to get the yaml package using, "sudo apt-get install build-essential python-yaml cmake subversion wget python-setuptools mercurial git-core", but terminal then says that python-yaml is already updated. How can I get this yaml module working properly?

No module named "yaml"

I installed ROS on Ubuntu 11.10 using the complete desktop install from ros.org. However, when I try to run roscore, I get the following error:

Traceback `Traceback (most recent call last):

File "/opt/ros/electric/ros/bin/roscore", line 34, in <module> from ros import roslaunch File "/opt/ros/electric/ros/core/roslib/src/ros/__init__.py", line 57, in __getattr__ return __import__(name) File "/opt/ros/electric/stacks/ros_comm/tools/roslaunch/src/roslaunch/__init__.py", line 43, in <module> import roslaunch.param_dump File "/opt/ros/electric/stacks/ros_comm/tools/roslaunch/src/roslaunch/param_dump.py", line 43, in <module> import yaml ImportError: No module named yamlyaml`

I found someone with the same problem here: http://answers.ros.org/question/12862/nao-error-no-module-named-yaml

I also tried to get the yaml package using, "sudo apt-get install build-essential python-yaml cmake subversion wget python-setuptools mercurial git-core", but terminal then says that python-yaml is already updated. How can I get this yaml module working properly?

click to hide/show revision 3
No.3 Revision

updated 2013-10-07 04:38:41 -0600

joq gravatar image

No module named "yaml"

I installed ROS on Ubuntu 11.10 using the complete desktop install from ros.org. However, when I try to run roscore, I get the following error:

 `Traceback (most recent call last):

File "/opt/ros/electric/ros/bin/roscore", line 34, in <module> from ros import roslaunch File "/opt/ros/electric/ros/core/roslib/src/ros/__init__.py", line 57, in __getattr__ return __import__(name) File "/opt/ros/electric/stacks/ros_comm/tools/roslaunch/src/roslaunch/__init__.py", line 43, in <module> import roslaunch.param_dump File "/opt/ros/electric/stacks/ros_comm/tools/roslaunch/src/roslaunch/param_dump.py", line 43, in <module> import yaml ImportError: No module named yaml`

yaml`

I found someone with the same problem here: http://answers.ros.org/question/12862/nao-error-no-module-named-yaml

I also tried to get the yaml package using, "sudo apt-get install build-essential python-yaml cmake subversion wget python-setuptools mercurial git-core", but terminal then says that python-yaml is already updated. How can I get this yaml module working properly?