Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

problem for navigation

Hi all,

I am trying to navigate my pioneer 3dx robot using move_base and cost files. I am using sicklms200 laser. I am running the robot using ROSARIA. I have written my own transformation node following tf tutorials and it works fine.

I could build the map using gmapping package. Also global lacalisation using AMCL package has worked well. I am using amcl_diff.launch file in the examples folder of amcl package.

I am then trying to navigate using move_base with the following supporting files. base_local_planner_params.yaml

    TrajectoryPlannerROS:
  max_vel_x: 0.8
  min_vel_x: 0.1
  max_rotational_vel: 0.8
  min_in_place_rotational_vel: 0.3
  backup_vel: -0.2

  sim_time: 2.0
  path_distance_bias: 0.6
  goal_distance_bias: 0.6

  acc_limit_th: 3.2
  acc_limit_x: 2.5
  acc_limit_y: 2.5

  holonomic_robot: false

costmap_common_params.yaml

    obstacle_range: 2.5
raytrace_range: 3.0
inflation_radius: 0.35


footprint: [ [0.3302, -0.0508], [0.254, -0.0508], [0.254, -0.254], [-0.254, -0.254], [-0.254, 0.254], [0.254, 0.254], [0.254, 0.0508], [0.3302, 0.0508] ]

transform_tolerance: 0.2
map_type: costmap

observation_sources: laser_scan_sensor

laser_scan_sensor: {sensor_frame: laser, data_type: LaserScan, topic: scan, marking: true, clearing: true, expected_update_rate: 0.2}

global_costmap_params.yaml

global_costmap:
  global_frame: /map
  robot_base_frame: base_link
  update_frequency: 2.0
  publish_frequency: 10.0
  static_map: true

local_costmap_params.yaml

local_costmap:
  global_frame: /odom
  robot_base_frame: base_link
  update_frequency: 5.0
  publish_frequency: 10.0
  static_map: false
  rolling_window: true
  width: 5.0
  height: 5.0
  resolution: 0.025

along with these I use a launch file for my move_base as navigation.launch

<launch>


    <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
        <rosparam file="$(find p2os_launch)/costmap_common_params.yaml" command="load" ns="global_costmap" />
        <rosparam file="$(find p2os_launch)/costmap_common_params.yaml" command="load" ns="local_costmap" />
        <rosparam file="$(find p2os_launch)/local_costmap_params.yaml" command="load" />
        <rosparam file="$(find p2os_launch)/global_costmap_params.yaml" command="load" />
        <rosparam file="$(find p2os_launch)/base_local_planner_params.yaml" command="load" />
        <param name="base_global_planner" type="string" value="NavfnROS" />
        <param name="conservative_reset_dist" type="double" value="3.0" />
        <param name="controller_frequency" type="double" value="15.0" />
    </node>
</launch>

on running these I can see all the topics in my rviz also the inflated obstacle and if I give a path it also plans the path and I can see that in rviz, but it doesn't move. The laptop hangs for sometime and then I see in my terminal the following errors.

[ WARN] [1331748630.289077383]: [/move_base]:Sensor data is out of date, we're not going to allow commanding of the base for safety
[ WARN] [1331748630.331339888]: Map update loop missed its desired rate of 10.0000Hz... the loop actually took 2.4046 seconds
[ WARN] [1331748630.355892025]: [/move_base]:Sensor data is out of date, we're not going to allow commanding of the base for safety
[ WARN] [1331748630.422665254]: [/move_base]:Sensor data is out of date, we're not going to allow commanding of the base for safety
[ WARN] [1331748630.472304319]: The scan observation buffer has not been updated for 5.58 seconds, and it should be updated every 0.20 seconds.

and this error keeps on repeating. I also tried to close rviz and give goal using simple_navigation_goals as given in the tutorial. This time I see the robot move but it moves a little distance and stops and then again moves and stops and so on till it reaches its goal, and sometimes it just keeps rotating in its place.

we have tried lowering the controller_frequency to 10hz also publish_frequency to 0.3 hz but still no use.

I had see in other posting that we have to reduce the resolution of the map, I see that in my map.yaml file the resolution is 0.05 and the map is 4000x4000 pixels. I think if I change the resolution in the .yaml file to 0.5 then will the originality of the map still be maintained ?? will this lead to any error in motion visualisation??

please help me in fixing the problem, I will be happy to provide any further information.