Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

publish visualization_msgs/Marker.h with rosserial.

I'm trying to publish marker to rviz with rosserial. I use Arduino Mega 2560 , ubuntu 14.04 and ROS indigo. in every time I run the arduino node after uploading the code on arduino board, an error "Tried to publish before configured, topic id 125" appers. this is the code I use https://github.com/toqaelshahat/marker/blob/master/marker.ino why does this error appear and how to handle it and what is the wrong with the code ?

publish visualization_msgs/Marker.h with rosserial.

I'm trying to publish marker to rviz with rosserial. I use Arduino Mega 2560 , ubuntu 14.04 and ROS indigo. in every time I run the arduino node after uploading the code on arduino board, an error "Tried to publish before configured, topic id 125" appers. this is the code I use https://github.com/toqaelshahat/marker/blob/master/marker.ino why does this error appear and how to handle it and what is the wrong with the code ?

publish visualization_msgs/Marker.h with rosserial.

I'm trying to publish marker to rviz with rosserial. I use Arduino Mega 2560 , ubuntu 14.04 and ROS indigo. in every time I run the arduino node after uploading the code on arduino board, an error "Tried "[ERROR] [WallTime: 1529597748.845483] Tried to publish before configured, topic id 125" 125 " appers. this is the code I use https://github.com/toqaelshahat/marker/blob/master/marker.ino why does this error appear and how to handle it and what is the wrong with the code ?