Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

how can I use two model in rviz ?

I use two laser sensor(sick_tim551 2050001) in my robot.

when I use two laser sensor in my robot it seems to work as one.

Also, In rviz, there is only one sensor model, and operate as one.

How can I use two sensor model in rviz and operate separately each sensor.

plz help. :(

how can I use two model in rviz ?

I use two laser sensor(sick_tim551 2050001) in my robot.

when I use two laser sensor in my robot it seems to work as one.

Also, In rviz, there is only one sensor model, and operate as one.

How can I use two sensor model in rviz and operate separately each sensor.

plz help. :(

oh. I'm sorry. Here is my launch file.

<group ns="lidar1"> <node name="robot_state_publisher" pkg="robot_state_publisher" type="state_publisher"/> <node name="sick_tim551_2050001" pkg="sick_tim" type="sick_tim551_2050001" respawn="false" output="screen"> </node> </group>

<launch>

<group ns="lidar2"> <node name="robot_state_publisher" pkg="robot_state_publisher" type="state_publisher"/> <node name="sick_tim551_2050001" pkg="sick_tim" type="sick_tim551_2050001" respawn="false" output="screen"> </node> <group>

</launch>

I seperate two sensors with group ns . Also I saw ,using rqt_graph, each sick_tim551_2050001 node share just one TF Node.

how can I use two model in rviz ?

I use two laser sensor(sick_tim551 2050001) in my robot.

when I use two laser sensor in my robot it seems to work as one.

Also, In rviz, there is only one sensor model, and operate as one.

How can I use two sensor model in rviz and operate separately each sensor.

plz help. :(

oh. I'm sorry. Here is my launch file.

<group ns="lidar1">
          <param name="robot_description" command="$(find xacro)/xacro --inorder '$(find sick_tim)/urdf/example.urdf.xacro'" />
         <node name="robot_state_publisher" pkg="robot_state_publisher" type="state_publisher"/>
type="state_publisher" />
         <node name="sick_tim551_2050001" pkg="sick_tim" type="sick_tim551_2050001" respawn="false" output="screen">
            <param name="hostname" type="string" value="172.16.1.209" />
         <param name="port" type="string" value="2111" />
         <param name="timelimit" type="int" value="5" />
  </node>
</group>

<launch>

</group> <launch> <group ns="lidar2"> <param name="robot_description" command="$(find xacro)/xacro --inorder '$(find sick_tim)/urdf/example.urdf.xacro'" /> <node name="robot_state_publisher" pkg="robot_state_publisher" type="state_publisher"/> type="state_publisher" /> <node name="sick_tim551_2050001" pkg="sick_tim" type="sick_tim551_2050001" respawn="false" output="screen"> <param name="hostname" type="string" value="169.254.12.60" /> <param name="port" type="string" value="2112" /> <param name="timelimit" type="int" value="5" /> </node> <group>

</launch>

<group> </launch>

I seperate two sensors with group ns . Also I saw ,using rqt_graph, each sick_tim551_2050001 node share just one TF Node.