Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Adding NaoQI API to PYTHONPATH (v1.12)

Hello, I am trying to set up ROS on my Nao robot. I keep getting the error: "Please make sure that Aldebaran's NaoQI API is in your PYTHONPATH." I found the answer below:

http://answers.ros.org/question/28814/adding-naoqi-to-the-pythonpath

and executed

PYTHONPATH=/my/path/to/naoqi-sdk-1.12-linux32/lib:${PYTHONPATH} ,

with "/my/path/to" being the path to the SDK in my system, but the error did not go away. I am using naoqi-sdk-1.12-linux32, so is the path different for this newer version?

Adding NaoQI API to PYTHONPATH (v1.12)

Hello, I am trying to set up ROS on my Nao robot. I keep getting the error: "Please make sure that Aldebaran's NaoQI API is in your PYTHONPATH." I found the answer below:

http://answers.ros.org/question/28814/adding-naoqi-to-the-pythonpath

and executed

PYTHONPATH=/my/path/to/naoqi-sdk-1.12-linux32/lib:${PYTHONPATH} ,

with "/my/path/to" being the path to the SDK in my system, but the error did not go away. I am using naoqi-sdk-1.12-linux32, so is the path different for this newer version?

Adding NaoQI API to PYTHONPATH (v1.12)

Hello, I am trying to set up ROS on my Nao robot. I keep getting the error: "Please make sure that Aldebaran's NaoQI API is in your PYTHONPATH." I found the answer below:

http://answers.ros.org/question/28814/adding-naoqi-to-the-pythonpath

and executed

PYTHONPATH=/my/path/to/naoqi-sdk-1.12-linux32/lib:${PYTHONPATH} ,

with "/my/path/to" being the path to the SDK in my system, but the error did not go away. I am using naoqi-sdk-1.12-linux32, so is the path different for this newer version?