Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

RVIZ: Wheel transforms not turning when using joint state controllers

I have an RC car in Gazebo made up of several links and joints. The two front wheels are attached with a steering joint (revolute) and all wheels are attached with continous joints. On the front wheels and for the steering joints transmissions and effort controllers have been added - NOTE: only on the front wheels!

I have finally managed to get my car moving after solving an inertia related problem. However I am not sure that my car is really working properly, because if I look at the TF's in RVIZ the front wheel TF's are not really rotating even though the car is moving based on a control input, causing the front wheels to move. However the steering angle is shown correctly in RVIZ and seems to match Gazebo.

  1. Why does the front wheels (with transmission and controllers attached) when the car is indeed driving due to these wheels turning? Front wheels not rotating in RVIZ

  2. Why are the rear wheel TF's not published when there is no transmission attached to them? Would I have to publish these from Gazebo manually (eg. I tried making a script which takes the Gazebo pose of the wheels and then publishes it as a TF from map to the wheel link)? Rear wheel TF's not published

If you want to try it out yourself the project can be downloaded here: https://github.com/mindThomas/JetsonCar-Simulation/

Best regards, Thomas Jespersen

RVIZ: Wheel transforms not turning when using joint state controllers

I have an RC car in Gazebo made up of several links and joints. The two front wheels are attached with a steering joint (revolute) and all wheels are attached with continous joints. On the front wheels and for the steering joints transmissions and effort controllers have been added - NOTE: only on the front wheels!

I have finally managed to get my car moving after solving an inertia related problem. However I am not sure that my car is really working properly, because if I look at the TF's in RVIZ the front wheel TF's are not really rotating even though the car is moving based on a control input, causing the front wheels to move. However the steering angle is shown correctly in RVIZ and seems to match Gazebo.

  1. Why does the front wheels (with transmission and controllers attached) not turn when the car is indeed driving due to these wheels turning? Front wheels not rotating in RVIZ

  2. Why are the rear wheel TF's not published when there is no transmission attached to them? Would I have to publish these from Gazebo manually (eg. I tried making a script which takes the Gazebo pose of the wheels and then publishes it as a TF from map to the wheel link)? Rear wheel TF's not published

If you want to try it out yourself the project can be downloaded here: https://github.com/mindThomas/JetsonCar-Simulation/

Best regards, Thomas Jespersen