Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

dwb_local_planner

I am trying to implement the robot_navigation package into my robot. I clone the the entire robot_navigation folder into my catkin workspace and use catkin isolated make because when doing the regular catkin build it gives me a CMake Error "This workspace contains non-catkin packages in it, and catkin cannot build a non-homogeneous workspace without isolation....". The isolated build works, but when trying to run plan_node.launch in the dwb_local_planner/launch folder using roslaunch results in the error "ERROR: cannot launch node of type [dwb_local_planner/planner_node]: can't locate node [planner_node] in package [dwb_local_planner]. I have researched and everything I could find saying it wasn't sourced, but to my knowledge I did source it correctly. When running my other launch files in a separate folder it works correctly, but the terminal outputs the following:

[FATAL] [1517335343.278669007, 0.826000000]: Failed to create the dwb_local_planner/DWAPlannerROS planner, are you sure it is properly registered and that the containing library is built? Exception: According to the loaded plugin descriptions the class dwb_local_planner/DWAPlannerROS with base class type nav_core::BaseLocalPlanner does not exist. Declared types are base_local_planner/TrajectoryPlannerROS dwa_local_planner/DWAPlannerROS nav_core_adapter::LocalPlannerAdapter [move_base-11] process has died [pid 28932, exit code 1, cmd /opt/ros/kinetic/lib/move_base/move_base cmd_vel:=/robot_diff_drive_controller/cmd_vel __name:=move_base __log:=/home/USR/.ros/log/b1f50d24-05e7-11e8-a9e0-6c0b84aabb26/move_base-11.log]. log file: /home/USR/.ros/log/b1f50d24-05e7-11e8-a9e0-6c0b84aabb26/move_base-11*.log

My question is if anyone knows why it isn't launching correctly?

dwb_local_planner

I am trying to implement the robot_navigation package into my robot. I clone the the entire robot_navigation folder into my catkin workspace and use catkin isolated make because when doing the regular catkin build it gives me a CMake Error "This workspace contains non-catkin packages in it, and catkin cannot build a non-homogeneous workspace without isolation....". The isolated build works, but when trying to run plan_node.launch in the dwb_local_planner/launch folder using roslaunch results in the error "ERROR: cannot launch node of type [dwb_local_planner/planner_node]: can't locate node [planner_node] in package [dwb_local_planner]. I have researched and everything I could find saying it wasn't sourced, but to my knowledge I did source it correctly. When running my other launch files in a separate folder it works correctly, but the terminal outputs the following:

[FATAL] [1517335343.278669007, 0.826000000]: Failed to create the dwb_local_planner/DWAPlannerROS planner, are you sure it is properly registered and that the containing library is built? Exception: According to the loaded plugin descriptions the class dwb_local_planner/DWAPlannerROS with base class type nav_core::BaseLocalPlanner does not exist. Declared types are base_local_planner/TrajectoryPlannerROS dwa_local_planner/DWAPlannerROS nav_core_adapter::LocalPlannerAdapter [move_base-11] process has died [pid 28932, exit code 1, cmd /opt/ros/kinetic/lib/move_base/move_base cmd_vel:=/robot_diff_drive_controller/cmd_vel __name:=move_base __log:=/home/USR/.ros/log/b1f50d24-05e7-11e8-a9e0-6c0b84aabb26/move_base-11.log]. log file: /home/USR/.ros/log/b1f50d24-05e7-11e8-a9e0-6c0b84aabb26/move_base-11*.log

My question is if anyone knows why it isn't launching correctly?

dwb_local_plannerdwa_local_planner

I am trying to implement the robot_navigation package into my robot. I clone the the entire robot_navigation folder into my catkin workspace and use catkin isolated make because when doing the regular catkin build it gives me a CMake Error "This workspace contains non-catkin packages in it, and catkin cannot build a non-homogeneous workspace without isolation....". The isolated build works, but when trying to run plan_node.launch in the dwb_local_planner/launch folder using roslaunch results in the error "ERROR: cannot launch node of type [dwb_local_planner/planner_node]: can't locate node [planner_node] in package [dwb_local_planner]. I have researched and everything I could find saying it wasn't sourced, but to my knowledge I did source it correctly. When running my other launch files in a separate folder it works correctly, but the terminal outputs the following:

[FATAL] [1517335343.278669007, 0.826000000]: Failed to create the dwb_local_planner/DWAPlannerROS planner, are you sure it is properly registered and that the containing library is built? Exception: According to the loaded plugin descriptions the class dwb_local_planner/DWAPlannerROS with base class type nav_core::BaseLocalPlanner does not exist. Declared types are base_local_planner/TrajectoryPlannerROS dwa_local_planner/DWAPlannerROS nav_core_adapter::LocalPlannerAdapter [move_base-11] process has died [pid 28932, exit code 1, cmd /opt/ros/kinetic/lib/move_base/move_base cmd_vel:=/robot_diff_drive_controller/cmd_vel __name:=move_base __log:=/home/USR/.ros/log/b1f50d24-05e7-11e8-a9e0-6c0b84aabb26/move_base-11.log]. log file: /home/USR/.ros/log/b1f50d24-05e7-11e8-a9e0-6c0b84aabb26/move_base-11*.log

My question is if anyone knows why it isn't launching correctly?

click to hide/show revision 4
None

dwa_local_plannerdwb_local_planner

I am trying to implement the robot_navigation package into my robot. I clone the the entire robot_navigation folder into my catkin workspace and use catkin isolated make because when doing the regular catkin build it gives me a CMake Error "This workspace contains non-catkin packages in it, and catkin cannot build a non-homogeneous workspace without isolation....". The isolated build works, but when trying to run plan_node.launch in the dwb_local_planner/launch folder using roslaunch results in the error "ERROR: cannot launch node of type [dwb_local_planner/planner_node]: can't locate node [planner_node] in package [dwb_local_planner]. I have researched and everything I could find saying it wasn't sourced, but to my knowledge I did source it correctly. When running my other launch files in a separate folder it works correctly, but the terminal outputs the following:

[FATAL] [1517335343.278669007, 0.826000000]: Failed to create the dwb_local_planner/DWAPlannerROS planner, are you sure it is properly registered and that the containing library is built? Exception: According to the loaded plugin descriptions the class dwb_local_planner/DWAPlannerROS with base class type nav_core::BaseLocalPlanner does not exist. Declared types are  base_local_planner/TrajectoryPlannerROS dwa_local_planner/DWAPlannerROS nav_core_adapter::LocalPlannerAdapter
 [move_base-11] process has died [pid 28932, exit code 1, cmd /opt/ros/kinetic/lib/move_base/move_base cmd_vel:=/robot_diff_drive_controller/cmd_vel __name:=move_base __log:=/home/USR/.ros/log/b1f50d24-05e7-11e8-a9e0-6c0b84aabb26/move_base-11.log].
 log file: /home/USR/.ros/log/b1f50d24-05e7-11e8-a9e0-6c0b84aabb26/move_base-11*.log

/home/USR/.ros/log/b1f50d24-05e7-11e8-a9e0-6c0b84aabb26/move_base-11*.log

My question is if anyone knows why it isn't launching correctly?