Ask Your Question

Revision history [back]

Did rospy remapping arguments change in Fuerte?

I'm having a weird error with remapping arguments on Fuerte. In my rospy node, I have a line like

baud_rate = rospy.param('~baud',4800)

so when I'd like to change that on the commandline, I tried

rosrun nmea_gps_driver nmea_gps_driver.py _baud:=38400

but instead of the parameter being set, I get the following error:

ERROR: Invalid remapping argument '_baud:=38400'

That remapping works just fine in Electric and I don't see anything in the rosrun or Fuerte Migration Guide.

In case it matters, I'm working against the latest Fuerte .debs on Ubuntu 11.10.

click to hide/show revision 2
Added minimal reproducible example

Did rospy remapping arguments change in Fuerte?

I'm having a weird error with remapping arguments on Fuerte. In my rospy node, I have a line like

baud_rate = rospy.param('~baud',4800)

so when I'd like to change that on the commandline, I tried

rosrun nmea_gps_driver nmea_gps_driver.py _baud:=38400

but instead of the parameter being set, I get the following error:

ERROR: Invalid remapping argument '_baud:=38400'

That remapping works just fine in Electric and I don't see anything in the rosrun or Fuerte Migration Guide.

In case it matters, I'm working against the latest Fuerte .debs on Ubuntu 11.10.

UPDATE:

Minimal reproducible example:

# test.py
import roslib
roslib.load_manifest('rospy')
import rospy

rospy.init_node('test_node')

test_param = rospy.get_param('~test', 4800)

print "Param was: %d" % (test_param)

If I run this like python test.py _test:=38400, I get the error output. See below.

$ python test.py _test:=38400
ERROR: Invalid remapping argument '_test:=38400'
Param was: 4800
$