Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

epos_hardware example not running failed setECmotorparameters

Hey, I have Problems using epos_hardware. I am using Ubuntu 16.04 and ROS Kinetic. I have already set up the motor and able to detect the motor (serial number) using list_devices. However, when i try to run the example.launch it gives me the error and unable to initialize the motors. it would be kind if you can help me out with this. Below please find the terminal output of rosrun epos_hardware list_devices and roslaunch epos_hardware example.launch respectively.

Roslaunch example:

auto-starting new master process[master]: started with pid [13988] ROS_MASTER_URI=http://localhost:11311

setting /run_id to 568ad142-d240-11e7-8333-34f39a7bd49b process[rosout-1]: started with pid [14001] started core service [/rosout] process[epos_hardware-2]: started with pid [14018] process[controller_spawner-3]: started with pid [14019] List_devices:

Listing Devices:

EPOS2

MAXON SERIAL V2

    USB

        USB0

            Baudrates:

                1000000

            Devices:

                Node Id: 1

        Serial Number: 0x602079025628

                    Hardware Version: 0x6220

                    Software Version: 0x2126

                    Application Number: 0x0

                    Application Version: 0x0

MAXON_RS232
    RS232
        Skipping RS232
CANopen

Could not get interface names: Bad Parameter EPOS MAXON_RS232 RS232 Skipping RS232 CANopen Could not get interface names: Bad Parameter