Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Link rospack to newer version of boost

I was follwing the ROS tutorials where I had to create the beginner tutorial package. I used the following command

catkin_create_pkg beginner_tutorials std_msgs rospy roscpp

After that when I tried out the follwing rospack command I got an error

 rospack depends1 beginner_tutorials

The error is

rospack: error while loading shared libraries : libboost_filesystem.so.1.63.0: cannot open shared object file: No such file or directory

Upon investigating, I realized that I have the boost version 1.65.1

How can I ask the ROS to look for the newer version of Boost?

Link rospack to newer version of boost

I was follwing the ROS tutorials where I had to create the beginner tutorial package. I used the following command

catkin_create_pkg beginner_tutorials std_msgs rospy roscpp

After that when I tried out the follwing rospack command I got an error

 rospack depends1 beginner_tutorials

The error is

rospack: error while loading shared libraries : libboost_filesystem.so.1.63.0: cannot open shared object file: No such file or directory

Upon investigating, I realized that I have the boost version 1.65.1

How can I ask the ROS to look for the newer version of Boost?