Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Robot model not showing in rviz

I am trying to work with this repository: https://github.com/udacity/RoboND-Kinematics-Project

I did all the initial steps that are mentioned in the repo but have troubles showing the robot urdf in rviz. Since the people over there can't help I hope that someone here can point me in the right direction.

When I just want to load the urdf in rviz like this (in individual shells):

roscore
rosrun rviz rviz
roslaunch kuka_arm load_urdf.launch

I just see the gripper. You can see this in the first photo attached.

The urdf to me looks fine and there are no errors anywhere.

When I run the whole demo, like this:

rosrun kuka_arm safe_spawner.sh

I can verify that the model is correctly loaded in gazebo as you can see in the second screenshot. I tried this on two computers, one in a VM, one natively and with integrated graphics and dedicated nvidia card.

Can anyone else please check the urdf and help me out in determining what the problem here is?

image description image description