Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

polygon_plugin tutorial

Hi there, I'm looking for some clarification: After following the plugin tutorial I'm ending up with this error:

The difficulty seems to be when working with the polygon_plugins.xml file (which seems to have some inconsistent text), ie where does it go, and which part of the tutorial should be in it.

Currently it looks like the example plugin xml before the writer looks deeper at the code, when some of the text starts to change.

Thanks in advance

polygon_plugin tutorial

Hi there, I'm looking for some clarification: After following the plugin tutorial I'm ending up with this error:

"$/home/carson/catkin_ws/src/pluginlib_tutorials_/src/polygon_plugins.xml" which had no Root Element. This likely means the XML is malformed or missing.

The difficulty seems to be when working with the polygon_plugins.xml file (which seems to have some inconsistent text), ie where does it go, and which part of the tutorial should be in it.

Currently it looks like the example plugin xml before the writer looks deeper at the code, when some of the text starts to change.

Thanks in advance

polygon_plugin tutorial

Hi there, I'm looking for some clarification: After following the plugin tutorial I'm ending up with this error:

"$/home/carson/catkin_ws/src/pluginlib_tutorials_/src/polygon_plugins.xml" which had no Root Element. This likely means the XML is malformed or missing.

The plugin failed to load for some reason. Error: According to the loaded plugin descriptions the class polygon_plugins::Triangle with base class type polygon_base::RegularPolygon does not exist.

The difficulty seems to be when working with the polygon_plugins.xml file (which seems to have some inconsistent text), ie where does it go, and which part of the tutorial should be in it.

Currently it looks like the example plugin xml before the writer looks deeper at the code, when some of the text starts to change.

Thanks in advance

polygon_plugin tutorial

Hi there, I'm looking for some clarification: After following the plugin tutorial I'm ending up with this error:

[ERROR] [1497996344.648813880]: Skipping XML Document "$/home/carson/catkin_ws/src/pluginlib_tutorials_/src/polygon_plugins.xml" which had no Root Element.  This likely means the XML is malformed or missing.

missing.

[ERROR] [1497996344.648951692]: The plugin failed to load for some reason. Error: According to the loaded plugin descriptions the class polygon_plugins::Triangle with base class type polygon_base::RegularPolygon does not exist.

exist.

The difficulty seems to be when working with the polygon_plugins.xml polygon_plugins.xml file (which seems to have some inconsistent text), ie where does it go, and which part of the tutorial should be in it.

Currently it looks like the example plugin xml before the writer looks deeper at the code, when some of the text starts to change.

Thanks in advance