Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Unable to install pointgrey_camera_driver

Hardware: Jetson TK1

OS: Ubuntu 14.04.4 LTS


QUESTION: How do I install the pointgrey_camera_driver? This command has not worked:

> sudo apt-get install ros-indigo-pointgrey-camera-driver

It gives me the following error:

E: Unable to locate package ros-indigo-pointgrey-camera-driver

Situation ROS (indigo) is installed. I am now trying to install flycapture2 and pointgrey_camera_driver (indigo).

I was trying to follow the instructions on:

  • http://wiki.ros.org/pointgrey_camera_driver

The last command I successfully ran was for Ubuntu 14.04 found on http://www.ptgrey.com/tan/10548

sudo apt-get install libraw1394-11 libgtkmm-2.4-1c2a libglademm-2.4-1c2a libgtkglextmm-x11-1.2-dev libgtkglextmm-x11-1.2 libusb-1.0-0

Then I tried to run the flycapture install script command:

sudo sh install_flycapture.sh

this yielded the following error:

sh: 0: Can't open install_flycapture.sh

I've also tried messing with udev rules unsuccessfully. Any ideas? I am slamming my head against a wall, if you can help, you will be sparing mankind of unnecessary building reconstruction!