Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Extrinsic calibration does not optimize

Hello, I am trying to calibrate the extrinsics of an Orbecc Astra and an Orbecc Astra S cameras using the updated tutorial of the ROS wiki one in indigo. I am using this fork of camera_pose for the indigo version.

I get to the launch of the camera_pose_calibration calibrate_2_camera.launch and it shows both windows of RGB (from bag) and IR (from live); furthermore, the two windows show a complete green line after a few seconds. However, I do not get any output from the launch file nor any data in the ".bag" file used to store the calibration.

This is the code I use to launch the camera (I am doing it one by one at a time):

<launch>
  <!-- Bring up Kinect and processing nodelets -->
  <include file="$(find astra_launch)/launch/astra.launch">
    <!-- Set cam info URLs, if not in the default location -->
    <!-- calib filess -->
     <arg name="rgb_camera_info_url"
          value="file:///home/adrian/CameraCalibration/pruebas/top/rgb_Orbbec_OrbbecMine.yaml" />
     <arg name="depth_camera_info_url"
          value="file:///home/adrian/CameraCalibration/pruebas/top/depth_Orbbec_OrbbecMine.yaml" />

    <!-- Suppress the default tf transforms (Fuerte only) -->
    <arg name="publish_tf" value="false" />
  </include>

  <!-- Extrinsic transform publisher -->
  <include file="$(find camera_pose_calibration)/blocks/calibration_tf_publisher.launch">
    <arg name="cache_file" value="./extrinsics_cache.bag" />
  </include>
</launch>

Any ideas of what the problem is?

Cheers