Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

urlopen error <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname<="" h3="">

I have a Intel RealSense robotic development kit. I installed Ubuntu 16.04.
$ which rosdep /usr/bin/rosdep $ rosdep --version 0.11.5 $ apt-cache policy python-rosdep python-rosdep: Installed: 0.11.5-1 Candidate: 0.11.5-1 Version table: * 0.11.5-1 500 500 http://packages.ros.org/ros/ubuntu xenial/main amd64 Packages 500 http://packages.ros.org/ros/ubuntu xenial/main i386 Packages 100 /var/lib/dpkg/status 0.11.4-2 500 500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages 500 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages

so version is not the problem. I'm able to ping raw.githubusercontent.com and get results

$ ping raw.githubusercontent.comPING raw.githubusercontent.com (151.101.48.133) 56(84) bytes of data. 64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=1 ttl=56 time=74.5 ms 64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=2 ttl=56 time=80.8 ms 64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=3 ttl=56 time=24.8 ms 64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=4 ttl=56 time=21.9 ms ^C --- raw.githubusercontent.com ping statistics --- 4 packets transmitted, 4 received, 0% packet loss, time 3004ms rtt min/avg/max/mdev = 21.915/50.552/80.889/27.279 ms

However, when I get to installing rosdep, I get this:

$ sudo apt -y install ros-kinetic-desktop-full python-rosinstall ros-kinetic-realsense-camera [sudo] password for <>: Reading package lists... Done Building dependency tree
Reading state information... Done python-rosinstall is already the newest version (0.7.8-1). ros-kinetic-desktop-full is already the newest version (1.3.0-0xenial-20161211-213832-0800). ros-kinetic-realsense-camera is already the newest version (1.6.1-0xenial-20161204-170602-0800). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. $ sudo rosdep init Wrote /etc/ros/rosdep/sources.list.d/20-default.list Recommended: please run

rosdep update

$ rosdep update reading in sources list data from /etc/ros/rosdep/sources.list.d ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml]: <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml) ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml]: <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml) ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml]: <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml) ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml]: <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml) ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml]: Failed to download target platform data for gbpdistro: <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> Query rosdistro index https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml ERROR: error loading sources list: <urlopen error="" <urlopen="" error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> (https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml)>

I have no proxy on my Internet connection, either.

urlopen error <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname<="" h3="">

I have a Intel RealSense robotic development kit. I installed Ubuntu 16.04.

$ which rosdep
/usr/bin/rosdep
$ rosdep --version
0.11.5
$ apt-cache policy python-rosdep
python-rosdep:
  Installed: 0.11.5-1
  Candidate: 0.11.5-1
  Version table:
 * *** 0.11.5-1 500
        500 http://packages.ros.org/ros/ubuntu xenial/main amd64 Packages
        500 http://packages.ros.org/ros/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status
     0.11.4-2 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages

Packages

so version is not the problem. I'm able to ping raw.githubusercontent.com and get results

$ ping raw.githubusercontent.comPING raw.githubusercontent.com (151.101.48.133) 56(84) bytes of data.
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=1 ttl=56 time=74.5 ms
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=2 ttl=56 time=80.8 ms
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=3 ttl=56 time=24.8 ms
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=4 ttl=56 time=21.9 ms
^C
--- raw.githubusercontent.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 21.915/50.552/80.889/27.279 ms

ms

However, when I get to installing rosdep, I get this:

$ sudo apt -y install ros-kinetic-desktop-full python-rosinstall ros-kinetic-realsense-camera
[sudo] password for <>: 
Reading package lists... Done
Building dependency tree 
Reading state information... Done python-rosinstall is already the newest version (0.7.8-1). ros-kinetic-desktop-full is already the newest version (1.3.0-0xenial-20161211-213832-0800). ros-kinetic-realsense-camera is already the newest version (1.6.1-0xenial-20161204-170602-0800). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. $ sudo rosdep init Wrote /etc/ros/rosdep/sources.list.d/20-default.list Recommended: please run

run

    rosdep update

$ rosdep update reading in sources list data from /etc/ros/rosdep/sources.list.d ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml]: <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml) ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml]: <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml) ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml]: <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml) ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml]: <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml) ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml]: Failed to download target platform data for gbpdistro: <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> error [Errno -5] No address associated with hostname> Query rosdistro index https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml ERROR: error loading sources list: <urlopen error="" <urlopen="" error="" [errno="" -5]="" no="" address="" associated="" with="" hostname=""> (https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml)>

error <urlopen error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml)>

I have no proxy on my Internet connection, either. either.

urlopen error <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname<="" h3="">

I have a Intel RealSense robotic development kit. I installed Ubuntu 16.04.

$ which rosdep
/usr/bin/rosdep
$ rosdep --version
0.11.5
$ apt-cache policy python-rosdep
python-rosdep:
  Installed: 0.11.5-1
  Candidate: 0.11.5-1
  Version table:
 *** 0.11.5-1 500
        500 http://packages.ros.org/ros/ubuntu xenial/main amd64 Packages
        500 http://packages.ros.org/ros/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status
     0.11.4-2 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages

so version is not the problem. I'm able to ping raw.githubusercontent.com and get results

$ ping raw.githubusercontent.comPING raw.githubusercontent.com (151.101.48.133) 56(84) bytes of data.
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=1 ttl=56 time=74.5 ms
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=2 ttl=56 time=80.8 ms
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=3 ttl=56 time=24.8 ms
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=4 ttl=56 time=21.9 ms
^C
--- raw.githubusercontent.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 21.915/50.552/80.889/27.279 ms

However, when I get to installing rosdep, I get this:

$ sudo apt -y install ros-kinetic-desktop-full python-rosinstall ros-kinetic-realsense-camera
[sudo] password for <>: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-rosinstall is already the newest version (0.7.8-1).
ros-kinetic-desktop-full is already the newest version (1.3.0-0xenial-20161211-213832-0800).
ros-kinetic-realsense-camera is already the newest version (1.6.1-0xenial-20161204-170602-0800).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
$ sudo rosdep init
Wrote /etc/ros/rosdep/sources.list.d/20-default.list
Recommended: please run

    rosdep update
$ rosdep update
reading in sources list data from /etc/ros/rosdep/sources.list.d
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml]:
    <urlopen error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml]:
    <urlopen error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml]:
    <urlopen error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml]:
    <urlopen error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml]:
    Failed to download target platform data for gbpdistro:
    <urlopen error [Errno -5] No address associated with hostname>
Query rosdistro index https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml
ERROR: error loading sources list:
    <urlopen error <urlopen error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml)>

I have no proxy on my Internet connection, either.

urlopen error <urlopen error="" [errno="" -5]="" no="" address="" associated="" with="" hostname<="" h3="">

I have a Intel RealSense robotic development kit. I installed Ubuntu 16.04.

$ which rosdep
/usr/bin/rosdep
$ rosdep --version
0.11.5
$ apt-cache policy python-rosdep
python-rosdep:
  Installed: 0.11.5-1
  Candidate: 0.11.5-1
  Version table:
 *** 0.11.5-1 500
        500 http://packages.ros.org/ros/ubuntu xenial/main amd64 Packages
        500 http://packages.ros.org/ros/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status
     0.11.4-2 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages

so version is not the problem. I'm able to ping raw.githubusercontent.com and get results

$ ping raw.githubusercontent.comPING raw.githubusercontent.com (151.101.48.133) 56(84) bytes of data.
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=1 ttl=56 time=74.5 ms
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=2 ttl=56 time=80.8 ms
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=3 ttl=56 time=24.8 ms
64 bytes from raw.githubusercontent.com (151.101.48.133): icmp_seq=4 ttl=56 time=21.9 ms
^C
--- raw.githubusercontent.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 21.915/50.552/80.889/27.279 ms

However, when I get to installing rosdep, I get this:

$ sudo apt -y install ros-kinetic-desktop-full python-rosinstall ros-kinetic-realsense-camera
[sudo] password for <>: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
python-rosinstall is already the newest version (0.7.8-1).
ros-kinetic-desktop-full is already the newest version (1.3.0-0xenial-20161211-213832-0800).
ros-kinetic-realsense-camera is already the newest version (1.6.1-0xenial-20161204-170602-0800).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
$ sudo rosdep init
Wrote /etc/ros/rosdep/sources.list.d/20-default.list
Recommended: please run

    rosdep update
$ rosdep update
reading in sources list data from /etc/ros/rosdep/sources.list.d
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml]:
    <urlopen error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml]:
    <urlopen error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml]:
    <urlopen error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml]:
    <urlopen error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml]:
    Failed to download target platform data for gbpdistro:
    <urlopen error [Errno -5] No address associated with hostname>
Query rosdistro index https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml
ERROR: error loading sources list:
    <urlopen error <urlopen error [Errno -5] No address associated with hostname> (https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml)>

I have no proxy on my Internet connection, either.