Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

AMCL usage error

Hello, i'm really new in ros, so here's my question:

With AMCL how do i localize the robot?

I got the following warning continually on amcl node:

  [ WARN] [1425574394.999492201]: No laser scan received (and thus no pose updates 
  have been published) for 1425574394.999407 seconds.  Verify that data is being published
  on the /scan topic.

  [ WARN] [1425574394.999585497]: MessageFilter [target=odom ]: Dropped 100.00% of 
  messages so far. Please turn the [ros.amcl.message_notifier] rosconsole logger to DEBUG
  for more information.

but i have data on the /scan topic.

And in rviz, under "global status" i got:

No tf data. Actual error: Fixed Frame [map] does not exist

I've searched for it and many people say that it is related with some /tf transform that I need to change.

Can some of you give me a hint on how to solve this?

AMCL usage error

Hello, i'm really new in ros, so here's my question:

With AMCL how do i localize the robot?

I got the following warning continually on amcl node:

  [ WARN] [1425574394.999492201]: No laser scan received (and thus no pose updates 
  have been published) for 1425574394.999407 seconds.  Verify that data is being published
  on the /scan topic.

  [ WARN] [1425574394.999585497]: MessageFilter [target=odom ]: Dropped 100.00% of 
  messages so far. Please turn the [ros.amcl.message_notifier] rosconsole logger to DEBUG
  for more information.

but i have data on the /scan topic.

And in rviz, under "global status" i got:

No tf data. Actual error: Fixed Frame [map] does not exist

I've searched for it and many people say that it is related with some /tf transform that I need to change.

Can some of you give me a hint on how to solve this?