Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Problem building ROS Kinetic (qt_gui_cpp) Fedora 24

I am a beginner about ROS. I have followed this tutorial to build ROS from source on Fedora 24.

At some point, I have this error:

==> Processing catkin package: 'qt_gui_cpp'
==> Building with env: '/home/user/ros_catkin_ws/install_isolated/env.sh'
Makefile exists, skipping explicit cmake invocation...
==> make cmake_check_build_system in '/home/user/ros_catkin_ws/build_isolated/qt_gui_cpp'
==> make -j4 -l4 in '/home/user/ros_catkin_ws/build_isolated/qt_gui_cpp'
[ 83%] Built target qt_gui_cpp
[ 88%] Running SIP generator for qt_gui_cpp_sip Python bindings...
sip: Deprecation warning: qt_gui_cpp.sip:1: %Module version number should be specified using the 'version' argument
sip: Unable to find file "QtCore/QtCoremod.sip"
Traceback (most recent call last):
  File "/home/user/ros_catkin_ws/install_isolated/share/python_qt_binding/cmake/sip_configure.py", line 76, in <module>
    subprocess.check_call(cmd)
  File "/usr/lib64/python2.7/subprocess.py", line 541, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['/usr/bin/sip', '-c', '/home/user/ros_catkin_ws/build_isolated/qt_gui_cpp/sip/qt_gui_cpp_sip', '-b', '/home/user/ros_catkin_ws/build_isolated/qt_gui_cpp/sip/qt_gui_cpp_sip/pyqtscripting.sbf', '-I', '/usr/share/sip/PyQt5', '-w', '-x', 'VendorID', '-t', 'WS_X11', '-t', 'Qt_5_6_1', '-x', 'Py_v3', 'qt_gui_cpp.sip']' returned non-zero exit status 1
src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/build.make:89: recipe for target 'sip/qt_gui_cpp_sip/Makefile' failed
make[2]: *** [sip/qt_gui_cpp_sip/Makefile] Error 1
CMakeFiles/Makefile2:374: recipe for target 'src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/all' failed
make[1]: *** [src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/all] Error 2
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2
<== Failed to process package 'qt_gui_cpp': 
  Command '['/home/user/ros_catkin_ws/install_isolated/env.sh', 'make', '-j4', '-l4']' returned non-zero exit status 2

Reproduce this error by running:
==> cd /home/user/ros_catkin_ws/build_isolated/qt_gui_cpp && /home/user/ros_catkin_ws/install_isolated/env.sh make -j4 -l4

Command failed, exiting.

I have multiple versions of Qt (Qt-3.3, Qt4 and Qt5) installed and I think I have to configure SIP but I don't how and what.

Can someone can help me or point me to the right direction?

Thanks.