Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Running Turtlebot_gazebo error

I'm trying to run turtlebot_gazebo but I have some problems. Here's the subject in details. I'm running ROS kinetic which is supposed that it can't link to gazebo as far as I know. I installed gazebo with the help of your site, however, the package I got and installed was called turtlebot_simulator, and turtlebot_gazebo was inside it (if I misunderstood the thing let me know). I tried to launch it using " $ roslaunch turtlebot_gazebo turtlebot_world.launch" but this didn't work. Finally, I browsed to folder "launch" inside turtlebot_gazebo and tried to launch it using "$ roslaunch turtlebot_world.launch" and it gives me the following error:

Invalid <arg> tag: environment variable 'TURTLEBOT_GAZEBO_WORLD_FILE' is not set.

Arg xml is <arg default="$(env TURTLEBOT_GAZEBO_WORLD_FILE)" name="world_file"/> The traceback for the exception was written to the log file

how can I fix it? Thank you