Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

ros node not working when using launch file.

Similar issue has been addressed in these two questions before hello node and output roslaunch. But I cannot get my node to work through the launch file. If I run the node like this:

./image_listener_test_node

it works everything is printed correctly. However through the launch file:

<launch>
    <node name="image_listener_test" type="image_listener_test_node" pkg="image_listener_test"  output="screen"/>

</launch>

Nothing is printed, is there something else I am missing?

ros node not working when using launch file.

Similar issue has been addressed in these two questions before hello node and output roslaunch. But I cannot get my node to work through the launch file. If I run the node like this:

./image_listener_test_node

it works everything is printed correctly. However through the launch file:

<launch>
    <node name="image_listener_test" type="image_listener_test_node" pkg="image_listener_test"  output="screen"/>

</launch>

Nothing is printed, is there something else I am missing?

ros node not working when using launch file.

Similar issue has been addressed in these two questions before hello node and output roslaunch. But I cannot get my node to work through the launch file. If I run the node like this:

./image_listener_test_node

it works everything is printed correctly. However through the launch file:

<launch>
    <node name="image_listener_test" type="image_listener_test_node" pkg="image_listener_test"  output="screen"/>

</launch>

Nothing is printed, is printed and no error message. Is there something else I am missing?missing?

ros node not working when using launch file.

Similar issue has been addressed in these two questions before hello node and output roslaunch. But I cannot get my node to work through the launch file. If I run the node like this:

./image_listener_test_node

it works everything is printed correctly. However through the launch file:

<launch>
    <node name="image_listener_test" type="image_listener_test_node" pkg="image_listener_test"  output="screen"/>

</launch>

Nothing is printed and no error message. Is there something else I am missing?