Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Unmet dependencies during Kinetic install on Odroid C2 / 16.04

Hi there,

I'm trying to set up Kinetic on an Odroid C2 with a fresh install of Ubuntu 16.04 LTS - latest image from hardkernel : http://odroid.com/dokuwiki/doku.php?id=en:c2_ubuntu_release_note_v1.2 - and getting dependencies errors :

odroid@odroid64:~$ sudo apt-get update
Hit:1 http://ppa.launchpad.net/saiarcot895/myppa/ubuntu xenial InRelease
Hit:2 http://deb.odroid.in/c2 xenial InRelease                                                            
Hit:3 http://ports.ubuntu.com/ubuntu-ports xenial InRelease                                               
Hit:4 http://ports.ubuntu.com/ubuntu-ports xenial-updates InRelease                                
Hit:5 http://ports.ubuntu.com/ubuntu-ports xenial-backports InRelease                              
Get:6 http://packages.ros.org/ros/ubuntu xenial InRelease [4,007 B]      
Hit:7 http://ports.ubuntu.com/ubuntu-ports xenial-security InRelease                
Hit:8 http://ports.ubuntu.com/ubuntu-ports xenial-proposed InRelease
Get:9 http://packages.ros.org/ros/ubuntu xenial/main arm64 Packages [16.4 kB]
Get:10 http://packages.ros.org/ros/ubuntu xenial/main armhf Packages [154 kB]
Fetched 175 kB in 2s (70.6 kB/s)    
Reading package lists... Done

odroid@odroid64:~$ sudo apt-get install ros-kinetic-ros-base 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-kinetic-ros-base:armhf : Depends: ros-kinetic-actionlib:armhf but it is not going to be installed
                              Depends: ros-kinetic-bond-core:armhf but it is not going to be installed
                              Depends: ros-kinetic-class-loader:armhf but it is not going to be installed
                              Depends: ros-kinetic-dynamic-reconfigure:armhf but it is not going to be installed
                              Depends: ros-kinetic-nodelet-core:armhf but it is not going to be installed
                              Depends: ros-kinetic-pluginlib:armhf but it is not going to be installed
                              Depends: ros-kinetic-ros-core:armhf but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Restricted/Universe/Multiverse are enabled :

odroid@odroid64:~$ sudo cat /etc/apt/sources.list
deb http://ports.ubuntu.com/ubuntu-ports/ xenial main universe restricted multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ xenial main universe restricted multiverse

deb http://ports.ubuntu.com/ubuntu-ports/ xenial-updates main universe restricted multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ xenial-updates main universe restricted multiverse

deb http://ports.ubuntu.com/ubuntu-ports/ xenial-backports main restricted universe multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ xenial-backports main restricted universe multiverse

deb http://ports.ubuntu.com/ubuntu-ports/ xenial-security main restricted universe multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ xenial-security main restricted universe multiverse

deb http://ports.ubuntu.com/ubuntu-ports/ xenial-proposed main restricted universe multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ xenial-proposed main restricted universe multiverse


odroid@odroid64:~$ sudo cat /etc/apt/sources.list.d/ros-latest.list 
deb http://packages.ros.org/ros/ubuntu xenial main

Just found this very similar question without solution : http://answers.ros.org/question/234911/missing-dependencies-kinetic-on-arm-with-ubuntu-1604-64-bit/

Any clues?

Thanks!