Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Make a map and navigate with it not working

I have followed the following tutorial: http://wiki.ros.org/turtlebot_gazebo/Tutorials/indigo/Make%20a%20map%20and%20navigate%20with%20it And have successfully created a map and saved both the .yaml and .pgm files. After running turtlebot_world, I run my customized map and do not receive any errors but get stuck with the message "odom received!". Nothing happens after this message and the customized map does not appear. Could I have help on why this is happening and how to fix it? Thanks in advance!

Make a map and navigate with it not working

I have followed the following tutorial: http://wiki.ros.org/turtlebot_gazebo/Tutorials/indigo/Make%20a%20map%20and%20navigate%20with%20it And have successfully created a map and saved both the .yaml and .pgm files. After running turtlebot_world, I run my customized map and do not receive any errors but get stuck with the message "odom received!". Nothing happens after this message and the customized map does not appear. Could I have help on why this is happening and how to fix it? Thanks in advance!

(I am using Virtual Box with Ubuntu 14.04 and Ros Indigo)

Make a map and navigate with it not working

I have followed the following tutorial: http://wiki.ros.org/turtlebot_gazebo/Tutorials/indigo/Make%20a%20map%20and%20navigate%20with%20it And have successfully created a map and saved both the .yaml and .pgm files. After running turtlebot_world, I run my customized map and do not receive any errors but get stuck with the message "odom received!". Nothing happens after this message and the customized map does not appear. Could I have help on why this is happening and how to fix it? Thanks in advance!

(I am using Virtual Box with Ubuntu 14.04 and Ros Indigo)Indigo)

Do I need to have hardware for this to work? I am trying to simply do a simulation so I am not using any physical robot or camera.