Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

rosparam unable to find yaml file

I am following the navigation stack tutorial and an unable to launch the move_base node. rosparam is unable to find the yaml files with the costmap and planner configuration

error loading <rosparam> tag: 
file does not exist [~/ros_catkin_ws/src/erle_rover_2dnav/costmap_common_params.yaml]
 XML is <rosparam command="load" file="~/ros_catkin_ws/src/erle_rover_2dnav/costmap_common_params.yaml" ns="global_costmap"/>

The issue is the same as in this question, http://answers.ros.org/question/64615/navigation-stack-rosparam-error-help/ but the suggested solution of deleting and remaking the file did not work for me. I have verified that the file is in the specified location and the code should be fine as it came directly from the navigation tutorial.

rosparam unable to find yaml file

I am following the navigation stack tutorial and an unable to launch the move_base node. rosparam is unable to find the yaml files with the costmap and planner configuration

error loading <rosparam> tag: 
file does not exist [~/ros_catkin_ws/src/erle_rover_2dnav/costmap_common_params.yaml]
 XML is <rosparam command="load" file="~/ros_catkin_ws/src/erle_rover_2dnav/costmap_common_params.yaml" ns="global_costmap"/>

The issue is the same as in this question, http://answers.ros.org/question/64615/navigation-stack-rosparam-error-help/ but the suggested solution of deleting and remaking the file did not work for me. I have verified that the file is in the specified location and the code should be fine as it came directly from the navigation tutorial.

EDIT- Here's the launch file and resulting error code when using find <launch> <master auto="start"/>

  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find erle_rover_2dnav)/src/erle_rover_2dnav/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find erle_rover_2dnav)/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find erle_rover_2dnav)/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find erle_rover_2dnav)/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find erle_rover_2dnav)/base_local_planner_params.yaml" command="load" />
  </node>
</launch>



error loading <rosparam> tag: 
file does not exist [/home/erle/ros_catkin_ws/install_isolated/share/erle_rover_2dnav/src/erle_rover_2dnav/costmap_common_params.yaml]

XML is <rosparam command="load" file="$(find erle_rover_2dnav)/src/erle_rover_2dnav/costmap_common_params.yaml" ns="global_costmap"/> The traceback for the exception was written to the log file

rosparam unable to find yaml file

I am following the navigation stack tutorial and an unable to launch the move_base node. rosparam is unable to find the yaml files with the costmap and planner configuration

error loading <rosparam> tag: 
file does not exist [~/ros_catkin_ws/src/erle_rover_2dnav/costmap_common_params.yaml]
 XML is <rosparam command="load" file="~/ros_catkin_ws/src/erle_rover_2dnav/costmap_common_params.yaml" ns="global_costmap"/>

The issue is the same as in this question, http://answers.ros.org/question/64615/navigation-stack-rosparam-error-help/ but the suggested solution of deleting and remaking the file did not work for me. I have verified that the file is in the specified location and the code should be fine as it came directly from the navigation tutorial.

EDIT- Here's the launch file and resulting error code when using find <launch> <master auto="start"/>find

<launch>
  <master auto="start"/>
  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find erle_rover_2dnav)/src/erle_rover_2dnav/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find erle_rover_2dnav)/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find erle_rover_2dnav)/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find erle_rover_2dnav)/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find erle_rover_2dnav)/base_local_planner_params.yaml" command="load" />
  </node>
</launch>



error loading <rosparam> tag: 
file does not exist [/home/erle/ros_catkin_ws/install_isolated/share/erle_rover_2dnav/src/erle_rover_2dnav/costmap_common_params.yaml]

XML is <rosparam command="load" file="$(find erle_rover_2dnav)/src/erle_rover_2dnav/costmap_common_params.yaml" ns="global_costmap"/> The traceback for the exception was written to the log file

rosparam unable to find yaml file

I am following the navigation stack tutorial and an unable to launch the move_base node. rosparam is unable to find the yaml files with the costmap and planner configuration

error loading <rosparam> tag: 
file does not exist [~/ros_catkin_ws/src/erle_rover_2dnav/costmap_common_params.yaml]
 XML is <rosparam command="load" file="~/ros_catkin_ws/src/erle_rover_2dnav/costmap_common_params.yaml" ns="global_costmap"/>

The issue is the same as in this question, http://answers.ros.org/question/64615/navigation-stack-rosparam-error-help/ but the suggested solution of deleting and remaking the file did not work for me. I have verified that the file is in the specified location and the code should be fine as it came directly from the navigation tutorial.

EDIT- Here's the launch file and resulting error code when using find

<launch>
  <master auto="start"/>
   <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find erle_rover_2dnav)/src/erle_rover_2dnav/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find erle_rover_2dnav)/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find erle_rover_2dnav)/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find erle_rover_2dnav)/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find erle_rover_2dnav)/base_local_planner_params.yaml" command="load" />
  </node>
</launch>



error loading <rosparam> tag: 
file does not exist [/home/erle/ros_catkin_ws/install_isolated/share/erle_rover_2dnav/src/erle_rover_2dnav/costmap_common_params.yaml]

XML is <rosparam command="load" file="$(find erle_rover_2dnav)/src/erle_rover_2dnav/costmap_common_params.yaml" ns="global_costmap"/> The traceback for the exception was written to the log file

file