Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Errors in Velodyne driver

Hi, I am working with a VLP-16. I am using the ros driver to get de pointcloud. However I think there are some mistakes in the driver. If you change the angle in the web, for example, using only 90 degrees, the total amount of points per scan changes, and in the driver is kept constant. When you change the rpm of the velodyne to 1200 the rate should be 20 Hz, however the driver still thinks te speed is 600rpm. I have made a couple of changes and I have been able to solve the problem with the angle by ading a new parameter, with the speed I have done something similar but it still have some issues.

Have anybody else seen those mistakes?

The best way to solve them would be retrieving the information directly from the velodyne, but that is not so easy and it would requiere a big effort from me (I am still new to this).

Thanks a lot!

Errors in Velodyne driver

Hi, I am working with a VLP-16. I am using the ros driver to get de pointcloud. However I think there are some mistakes in the driver. If you change the angle in the web, for example, using only 90 degrees, the total amount of points per scan changes, and in the driver is kept constant. When you change the rpm of the velodyne to 1200 the rate should be 20 Hz, however the driver still thinks te speed is 600rpm. I have made a couple of changes and I have been able to solve the problem with the angle by ading a new parameter, with the speed I have done something similar but it still have some issues.

Have anybody else seen those mistakes?

The best way to solve them would be retrieving the information directly from the velodyne, but that is not so easy and it would requiere a big effort from me (I am still new to this).

EDIT: I mean changind the angle and the speed here:

http://s2.subirimagenes.com/privadas/previo/thump_2372757captura-de-pantalla.png

If the angle is different from 359 it does not work well. It accumulates measurments until reach the equivalent number of points to 379 Hz, and therefore the laser rate decreases. For example, if yo select 90 degrees, it will work at Hz. With the rotational speed happens that even if you change the speed, lets say 1200 rpm, it should work at Hz, but it still works at 10. How do I open a git issue? I have been able to solve both problems using arguments, however I think that someone should make the driver to read the parameters from within the Velodyne

Thanks a lot!

Errors in Velodyne driver

Hi, I am working with a VLP-16. I am using the ros driver to get de pointcloud. However I think there are some mistakes in the driver. If you change the angle in the web, for example, using only 90 degrees, the total amount of points per scan changes, and in the driver is kept constant. When you change the rpm of the velodyne to 1200 the rate should be 20 Hz, however the driver still thinks te speed is 600rpm. I have made a couple of changes and I have been able to solve the problem with the angle by ading a new parameter, with the speed I have done something similar but it still have some issues.

Have anybody else seen those mistakes?

The best way to solve them would be retrieving the information directly from the velodyne, but that is not so easy and it would requiere a big effort from me (I am still new to this).

EDIT: I mean changind changing the angle and the speed here:

http://s2.subirimagenes.com/privadas/previo/thump_2372757captura-de-pantalla.png

If the angle is different from 359 it does not work well. It accumulates measurments until reach the equivalent number of points to 379 Hz, and therefore the laser rate decreases. For example, if yo select 90 degrees, it will work at Hz. With the rotational speed happens that even if you change the speed, lets say 1200 rpm, it should work at Hz, but it still works at 10. How do I open a git issue? I have been able to solve both problems using arguments, however I think that someone should make the driver to read the parameters from within the Velodyne

Thanks a lot!

Errors in Velodyne driver

Hi, I am working with a VLP-16. I am using the ros driver to get de pointcloud. However I think there are some mistakes in the driver. If you change the angle in the web, for example, using only 90 degrees, the total amount of points per scan changes, and in the driver is kept constant. When you change the rpm of the velodyne to 1200 the rate should be 20 Hz, however the driver still thinks te speed is 600rpm. I have made a couple of changes and I have been able to solve the problem with the angle by ading a new parameter, with the speed I have done something similar but it still have some issues.

Have anybody else seen those mistakes?

The best way to solve them would be retrieving the information directly from the velodyne, but that is not so easy and it would requiere a big effort from me (I am still new to this).

EDIT: I mean changing the angle and the speed here:

http://s2.subirimagenes.com/privadas/previo/thump_2372757captura-de-pantalla.png

If the angle is different from 359 it does not work well. It accumulates measurments until reach the equivalent number of points to 379 359 Hz, and therefore the laser rate decreases. For example, if yo select 90 degrees, it will work at Hz. How do I open a git issue? I have been able to solve both problems using arguments, however I think that someone should make the driver to read the parameters from within the Velodyne

Thanks a lot!