Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Kobuki Left Bumper stuck

My Kobuki left bumper has somehow gotten stuck, I could probably live with this, but it messes up the auto_docking node, which reports feedback: [dockdrive: bumped]: and my robot just backs up.

I've verified the behavior by running the following commands in order.

  • roscore
  • rostopic echo /mobile_base/events/bumper roslaunch
  • kobuki_node minimal.launch --screen

As soon as the kobuki_node comes up the echo report the following below. Also, the right and center bumper work as expected.

bumper: 0
state: 1

Pressing the left bumper has no effect on the echo command above. Ie. the Kobuki think the left bumper is always pressed. So I have two options:

Option 1: Find some documentation on how to take the bumper off and see why it's stuck.

Option 2: Get the auto_docking node to work despite the left bumper being stuck.**

Any ideas?

Thanks

Kobuki Left Bumper stuck

My Kobuki left bumper has somehow gotten stuck, I could probably live with this, but it messes up the auto_docking node, which reports feedback: [dockdrive: bumped]: and my robot just backs up.

I've verified the behavior by running the following commands in order.

  • roscore
  • rostopic echo /mobile_base/events/bumper roslaunch/mobile_base/events/bumper
  • roslaunch kobuki_node minimal.launch --screen

As soon as the kobuki_node comes up the echo report the following below. Also, the right and center bumper work as expected.

bumper: 0
state: 1

Pressing the left bumper has no effect on the echo command above. Ie. the Kobuki think the left bumper is always pressed. So I have two options:

Option 1: Find some documentation on how to take the bumper off and see why it's stuck.

Option 2: Get the auto_docking node to work despite the left bumper being stuck.**

Any ideas?

Thanks