Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

coffeebot webserver open problems

Hi!

I am currently using the LAMP stack as explained in the http://learn.turtlebot.com/2015/02/01/20/ tutorial. The goal is to order a coffee (robot driving to specific location) through a chrome extension. I am running the turtlebot_bringup minimal.launch and loaded my map on the turtlebot laptop. I installed the LAMP correctly and entered the public_dns where I had to. Here is my traceback:

nicolas@nicolas-Precision-WorkStation-T3400:~/helloworld/turtlebot$ python coffee_bot.py 
[INFO] [WallTime: 1437468105.504769] wait for the action server to come up
[INFO] [WallTime: 1437468105.787535] Anyone need coffee?
[INFO] [WallTime: 1437468105.808969] Notebook's battery is now: 68%
[INFO] [WallTime: 1437468105.811882] Kobuki's battery is now: 99.0%
[INFO] [WallTime: 1437468129.914613] Notebook's battery is now: 69%
Traceback (most recent call last):
  File "coffee_bot.py", line 298, in <module>
    while(coffebot.deliver_coffee() and not rospy.is_shutdown()):
  File "coffee_bot.py", line 102, in deliver_coffee
    data = json.load(urllib2.urlopen(self.server_public_dns + "/var/www/html/turtlebot-server/coffee_queue.php?pop"))
  File "/usr/lib/python2.7/urllib2.py", line 127, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib/python2.7/urllib2.py", line 404, in open
    response = self._open(req, data)
  File "/usr/lib/python2.7/urllib2.py", line 422, in _open
    '_open', req)
  File "/usr/lib/python2.7/urllib2.py", line 382, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.7/urllib2.py", line 1214, in http_open
    return self.do_open(httplib.HTTPConnection, req)
  File "/usr/lib/python2.7/urllib2.py", line 1184, in do_open
    raise URLError(err)
urllib2.URLError: <urlopen error timed out>

I changed the path from

self.server_public_dns + "/turtlebot-server/coffee_queue.php?pop

to:

self.server_public_dns + "/var/www/html/turtlebot-server/coffee_queue.php?pop

because when ssh into the server, this is where it is located. But either way it is not working. Can anyone help?

Thanks in advance! Cheers