Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

GDB does not run correctly with roslaunch

Hello all,

I am trying to use GDB with roslaunch but I dont know how to. In the .launch file I write

<node pkg="read_kinect_01" name="front_end" type="read_kinect_01_node" launch-prefix="gdb --args" output="streen"/>

but whenever I try to use a command it does not work. If I run "r" (to run) it will run and display and error like it alway does (even when I am not using GDB). But whenever I try to write

break 54

I get a message saying

No symbol table is loaded. Use the "file" command

If I try to run

print x

I get the same message.

After that I looked up "file" but was not able to find anything related to ROS that would help me. I tried

file /ROS/catkin_ws/devel/lib/read_kinect_01/read_kinect_01_node

among other attempts... but nothing (every single time :/ ). What exactly do I need to give to "file" so it will work?

I am using Ubuntu 14.04 LTS with ROS Indigo