Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Nav2d_karto mapper doesn't build a map

Hello,

I followed the nav2d tutorials to adapt it to a turtlebot. The first two tutorials work well but I have a problem with the 3rd one. I noticed that the mapper node from the nav2d_karto doesn't build a map: no frame are published and the map topic is empty.

I get this message when I run the launchfile: [ WARN] [1427816737.545498816]: MessageFilter [target=map ]: Dropped 95.01% of messages so far. Please turn the [ros.rviz.message_notifier] rosconsole logger to DEBUG for more information.

Sometimes it's 98% or 100% dropped. And the rviz screenshot related: http://hpics.li/14f0f88

Here is my launch file: <launch>

<include file="$(find turtlebot_bringup)/launch/3dsensor.launch"/>
<!-- Some general parameters -->
<param name="use_sim_time" value="false" />
<rosparam file="$(find robot_exploration)/param/ros.yaml"/>

<!-- Start the Operator to control the simulated robot -->
<node name="Operator" pkg="nav2d_operator" type="operator" >
    <remap from="cmd_vel" to="/teleop_velocity_smoother/raw_cmd_vel"/>
    <rosparam file="$(find nav2d_tutorials)/param/operator.yaml"/>
    <rosparam file="$(find nav2d_tutorials)/param/costmap.yaml" ns="local_map" />
</node>

<!-- to smooth the velocity -->
<include file="$(find turtlebot_teleop)/launch/includes/velocity_smoother.launch.xml"/>

<!-- Start Mapper to genreate map from laser scans -->
<node name="Mapper" pkg="nav2d_karto" type="mapper">
    <rosparam file="$(find nav2d_tutorials)/param/mapper.yaml"/>
</node>

<!-- Start the Navigator to move the robot autonomously -->
<node name="Navigator" pkg="nav2d_navigator" type="navigator">
    <rosparam file="$(find nav2d_tutorials)/param/navigator.yaml"/>
</node>

<node name="GetMap" pkg="nav2d_navigator" type="get_map_client" />
<node name="Explore" pkg="nav2d_navigator" type="explore_client" />
<node name="SetGoal" pkg="nav2d_navigator" type="set_goal_client" />

<!-- Start the joystick-driver and remote-controller for operation-->
<node name="Joystick" pkg="joy" type="joy_node" />
<node name="Remote" pkg="nav2d_remote" type="remote_joy" />

<!-- RVIZ to view the visualization -->
<node name="RVIZ" pkg="rviz" type="rviz" args=" -d $(find nav2d_tutorials)/param/tutorial3.rviz" />

</launch>

and the ros.yaml related:

Defines topics services and frames for all modules

TF frames
laser_frame: camera_link #base_laser_link
robot_frame: base_link
odometry_frame: odom
offset_frame: offset
map_frame: map

ROS topics
map_topic: map
laser_topic: scan #base_scan

ROS services
map_service: static_map

And finally the tf tree: http://hpics.li/a627710

Thank you in advance!

Nav2d_karto mapper doesn't build a map

Hello,

I followed the nav2d tutorials to adapt it to a turtlebot. The first two tutorials work well but I have a problem with the 3rd one. I noticed that the mapper node from the nav2d_karto doesn't build a map: no frame are published and the map topic is empty.

I get this message when I run the launchfile: [ WARN] [1427816737.545498816]: MessageFilter [target=map ]: Dropped 95.01% of messages so far. Please turn the [ros.rviz.message_notifier] rosconsole logger to DEBUG for more information. information.

Sometimes it's 98% or 100% dropped. dropped.

Edit: I checked the rosconsole in debug mode and I get two new messages:

First message:
MessageFilter [target=map ]: Added message in frame odom at time 1427987427.762, count now 10

Second message:
MessageFilter [target=map ]: Removed oldest message because buffer is full, count now 10 (frame_id=odom, stamp=1427987426.762333)

Here is the tf tree: tf_tree

And the rviz screenshot related: http://hpics.li/14f0f88

http://hpics.li/a627710 Here is my launch file: <launch>

<include file="$(find turtlebot_bringup)/launch/3dsensor.launch"/>
<!-- Some general parameters -->
<param name="use_sim_time" value="false" />
<rosparam file="$(find robot_exploration)/param/ros.yaml"/>

<!-- Start the Operator to control the simulated robot -->
<node name="Operator" pkg="nav2d_operator" type="operator" >
    <remap from="cmd_vel" to="/teleop_velocity_smoother/raw_cmd_vel"/>
    <rosparam file="$(find nav2d_tutorials)/param/operator.yaml"/>
    <rosparam file="$(find nav2d_tutorials)/param/costmap.yaml" ns="local_map" />
</node>

<!-- to smooth the velocity -->
<include file="$(find turtlebot_teleop)/launch/includes/velocity_smoother.launch.xml"/>

<!-- Start Mapper to genreate map from laser scans -->
<node name="Mapper" pkg="nav2d_karto" type="mapper">
    <rosparam file="$(find nav2d_tutorials)/param/mapper.yaml"/>
</node>

<!-- Start the Navigator to move the robot autonomously -->
<node name="Navigator" pkg="nav2d_navigator" type="navigator">
    <rosparam file="$(find nav2d_tutorials)/param/navigator.yaml"/>
</node>

<node name="GetMap" pkg="nav2d_navigator" type="get_map_client" />
<node name="Explore" pkg="nav2d_navigator" type="explore_client" />
<node name="SetGoal" pkg="nav2d_navigator" type="set_goal_client" />

<!-- Start the joystick-driver and remote-controller for operation-->
<node name="Joystick" pkg="joy" type="joy_node" />
<node name="Remote" pkg="nav2d_remote" type="remote_joy" />

<!-- RVIZ to view the visualization -->
<node name="RVIZ" pkg="rviz" type="rviz" args=" -d $(find nav2d_tutorials)/param/tutorial3.rviz" />

</launch>

and the ros.yaml related:

Defines topics services and frames for all modules

TF frames
laser_frame: camera_link #base_laser_link
robot_frame: base_link
odometry_frame: odom
offset_frame: offset
map_frame: map

ROS topics
map_topic: map
laser_topic: scan #base_scan

ROS services
map_service: static_map

And finally the tf tree: http://hpics.li/a627710

Thank you in advance!advance for any answer!

Nav2d_karto mapper doesn't build a map

Hello,

I followed the nav2d tutorials to adapt it to a turtlebot. The first two tutorials work well but I have a problem with the 3rd one. I noticed that the mapper node from the nav2d_karto doesn't build a map: no frame are published and the map topic is empty.

I get this message when I run the launchfile: [ WARN] [1427816737.545498816]: MessageFilter [target=map ]: Dropped 95.01% of messages so far. Please turn the [ros.rviz.message_notifier] rosconsole logger to DEBUG for more information.

Sometimes it's 98% or 100% dropped.

Edit: I checked the rosconsole in debug mode and I get two new messages:

First message:
MessageFilter [target=map ]: Added message in frame odom at time 1427987427.762, count now 10

Second message:
MessageFilter [target=map ]: Removed oldest message because buffer is full, count now 10 (frame_id=odom, stamp=1427987426.762333)

Here is the tf tree: tf_treehttp://hpics.li/a627710

And the rviz screenshot related: http://hpics.li/14f0f88

http://hpics.li/a627710 Here is my launch file: <launch>

<include file="$(find turtlebot_bringup)/launch/3dsensor.launch"/>
<!-- Some general parameters -->
<param name="use_sim_time" value="false" />
<rosparam file="$(find robot_exploration)/param/ros.yaml"/>

<!-- Start the Operator to control the simulated robot -->
<node name="Operator" pkg="nav2d_operator" type="operator" >
    <remap from="cmd_vel" to="/teleop_velocity_smoother/raw_cmd_vel"/>
    <rosparam file="$(find nav2d_tutorials)/param/operator.yaml"/>
    <rosparam file="$(find nav2d_tutorials)/param/costmap.yaml" ns="local_map" />
</node>

<!-- to smooth the velocity -->
<include file="$(find turtlebot_teleop)/launch/includes/velocity_smoother.launch.xml"/>

<!-- Start Mapper to genreate map from laser scans -->
<node name="Mapper" pkg="nav2d_karto" type="mapper">
    <rosparam file="$(find nav2d_tutorials)/param/mapper.yaml"/>
</node>

<!-- Start the Navigator to move the robot autonomously -->
<node name="Navigator" pkg="nav2d_navigator" type="navigator">
    <rosparam file="$(find nav2d_tutorials)/param/navigator.yaml"/>
</node>

<node name="GetMap" pkg="nav2d_navigator" type="get_map_client" />
<node name="Explore" pkg="nav2d_navigator" type="explore_client" />
<node name="SetGoal" pkg="nav2d_navigator" type="set_goal_client" />

<!-- Start the joystick-driver and remote-controller for operation-->
<node name="Joystick" pkg="joy" type="joy_node" />
<node name="Remote" pkg="nav2d_remote" type="remote_joy" />

<!-- RVIZ to view the visualization -->
<node name="RVIZ" pkg="rviz" type="rviz" args=" -d $(find nav2d_tutorials)/param/tutorial3.rviz" />

</launch>

and the ros.yaml related:

Defines topics services and frames for all modules

TF frames
laser_frame: camera_link #base_laser_link
robot_frame: base_link
odometry_frame: odom
offset_frame: offset
map_frame: map

ROS topics
map_topic: map
laser_topic: scan #base_scan

ROS services
map_service: static_map

Thank you in advance for any answer!