Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Install indigo to ubuntu 14.04.2(testing)

I'm trying to install indigo to ubuntu 14.04.2, which is testing version of ubuntu trusty, but I met conflict with HWE packages from utopic as follows:

$ sudo aptitude install ros-indigo-rviz
The following NEW packages will be installed:
 libdrm-dev{a} libgl1-mesa-dev{a} libgl1-mesa-dri{a} libgl1-mesa-glx{ab} libglapi-mesa{a} libglu1-mesa-dev{a} libllvm3.4{a} libphonon4{a} libpyside-dev{a} libpyside-py3-1.2{a} libpyside1.2{a} libqt4-dev{a} libqt4-dev-bin{a} libqt4-opengl-dev{a} libqt4-qt3support{a} libqtwebkit-dev{a} libshiboken-dev{a} libshiboken-py3-1.2{a} libshiboken1.2{a} libx11-xcb-dev{a} libxcb-dri2-0-dev{a} libxcb-dri3-dev{a} libxcb-glx0-dev{a} libxcb-present-dev{a} libxcb-randr0-dev{a} libxcb-shape0-dev{a} libxcb-sync-dev{a} libxcb-xfixes0-dev{a} libxshmfence-dev{a} libxxf86vm-dev{a} mesa-common-dev{a} phonon{a} phonon-backend-gstreamer{a} phonon-backend-gstreamer-common{a} phonon-backend-gstreamer1.0{a} python-pyside{a} python-pyside.phonon{a} python-pyside.qtcore{a} python-pyside.qtdeclarative{a} python-pyside.qtgui{a} python-pyside.qthelp{a} python-pyside.qtnetwork{a} python-pyside.qtopengl{a} python-pyside.qtscript{a} python-pyside.qtsql{a} python-pyside.qtsvg{a} python-pyside.qttest{a} python-pyside.qtuitools{a} python-pyside.qtwebkit{a} python-pyside.qtxml{a} python-qt4-dev{a} qt4-linguist-tools{a} qt4-qmake{a} ros-indigo-map-msgs{a} ros-indigo-media-export{a} ros-indigo-python-qt-binding{a} ros-indigo-rviz shiboken{a} x11proto-dri2-dev{a} x11proto-gl-dev{a} x11proto-xf86vidmode-dev{a}
0 packages upgraded, 61 newly installed, 0 to remove and 0 not upgraded.
Need to get 24.8 MB of archives. After unpacking 138 MB will be used.
The following packages have unmet dependencies:
libgl1-mesa-dri-lts-utopic : Conflicts: libgl1-mesa-dri but 10.1.3-0ubuntu0.3 is to be installed.
libgl1-mesa-glx-lts-utopic : Conflicts: libgl1 which is a virtual package.
                          Conflicts: libgl1-mesa-glx but 10.1.3-0ubuntu0.3 is to be installed.
xserver-xorg-lts-utopic : Conflicts: libgl1-mesa-dri (>= 0~) but 10.1.3-0ubuntu0.3 is to be installed.
                       Conflicts: libgl1-mesa-glx (>= 0~) but 10.1.3-0ubuntu0.3 is to be installed.
                       Conflicts: libglapi-mesa (>= 0~) but 10.1.3-0ubuntu0.3 is to be installed.
libgl1-mesa-glx : Conflicts: libgl1 which is a virtual package.
libglapi-mesa-lts-utopic : Conflicts: libglapi-mesa but 10.1.3-0ubuntu0.3 is to be installed.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.

HWE packages are needed to run ubuntu 14.04 in my hardware. How can I install indigo packages resolving the conflicts?