Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Install from source missing pcl related ros packages

Hello,

I'm using ros compiled from source since I'm building an app with Qt5, Vtk6, OpenCV3, and PCL 1.8.

Last time I did this, I compiled all my libraries and installed them to /usr/local.
I compiled ROS from source according to this guide: http://wiki.ros.org/indigo/Installation/Source

Everything seemed to work fine, I used source ~/ros_build/install_isolated/setup.bash and it found all my packages for me and worked fine. I've since then reformatted my computer due to intel / nvidia driver conflict breaking anything to do with my GPU. I followed the same install procedure more or less but now when I try to build my project, I get the following:

CMake Error at /home/dan/ros_build/install_isolated/share/catkin/cmake/catkinConfig.cmake:75 (find_package): Could not find a package configuration file provided by "pcl_conversions" with any of the following names:

pcl_conversionsConfig.cmake
pcl_conversions-config.cmake

Add the installation prefix of "pcl_conversions" to CMAKE_PREFIX_PATH or set "pcl_conversions_DIR" to a directory containing one of the above files. If "pcl_conversions" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): camera_trigger/CMakeLists.txt:7 (find_package)

Furthermore, it would seem nothing PCL related was installed with ROS. I've tried installing individual packages via roslocate and rosinstall according to here: http://answers.ros.org/question/10581/installing-ros-packages-from-source/ but the error is the same, probably due to no pcl_conversionsConfig.cmake being generated with the rosinstall.

I'm pretty stumped as to what I'm doing wrong, I thought installing the packages from source would work with rosinstall, but I can't find any *.cmake files that were generated. After source'ing the new setup.bash generated by rosinstall, I can rosmake the pcl_conversions package but it happily builds without a complaint. Yet still the above error occurs with my program.