Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Rqt_myPlugin can't subscribe node

Hello guys,

I have a GUI as a rqt plugin and I want to subscribe a topic but I can't see my rqt_plugin node on the rqt_graph. The topic which i want to subscribe is in the same machine, which I want to start my rqt_plugin. I have muliple machines and I start the rqt_graph at the another machine. At the another machine I see all the other topics and I see also the topic which I want to subscribe with my rqt_plugin.

Here is the creation of the publisher at machine A:

 pubCmd = n.advertise<std_msgs::String>("/sci/cmd", 10);

Here is the subscribing of the topic /sci/cmd at my rqt_plugin also at machine A:

ros::Subscriber sub = getNodeHandle().subscribe("/sci/cmd", 10, &ccgui::receiveSC, this);

I hope someone can help me :)

Rqt_myPlugin can't subscribe node

Hello guys,

I have a GUI as a rqt plugin and I want to subscribe a topic but I can't see my rqt_plugin node on the rqt_graph. The topic which i want to subscribe is in the same machine, which I want to start my rqt_plugin. I have muliple machines and I start the rqt_graph at the another machine. At the another machine I see all the other topics and I see also the topic which I want to subscribe with my rqt_plugin.

Here is the creation of the publisher at machine A:

 pubCmd = n.advertise<std_msgs::String>("/sci/cmd", 10);

Here is the subscribing of the topic /sci/cmd at my rqt_plugin also at machine A:

ros::Subscriber sub = getNodeHandle().subscribe("/sci/cmd", 10, &ccgui::receiveSC, this);

If now I published something, my rqt plugin receives nothing. I know that the publisher works correctly because I subscribed the topic with a normal node and I receive the messages.

I hope someone can help me :)

Rqt_myPlugin can't subscribe node

Hello guys,

I have a GUI as a rqt plugin and I want to subscribe a topic but I can't see my rqt_plugin node on the rqt_graph. The topic which i want to subscribe is in the same machine, which I want to start my rqt_plugin. I have muliple machines and I start the rqt_graph at the another machine. At the another machine I see all the other topics and I see also the topic which I want to subscribe with my rqt_plugin.

Here is the creation of the publisher at machine A:

 pubCmd = n.advertise<std_msgs::String>("/sci/cmd", 10);

Here is the subscribing of the topic /sci/cmd at my rqt_plugin also at machine A:

ros::Subscriber sub = getNodeHandle().subscribe("/sci/cmd", 10, &ccgui::receiveSC, this);

If now I published something, my rqt plugin receives nothing. I know that the publisher works correctly because I subscribed the topic with a normal node and I receive the messages. https://github.com/Mosa-/rqt_ccgui

I hope someone can help me :)