Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

rplidar driver installation problem on Ubuntu

Apologies for posting here, but since robopeak's rplidar does not seem to have very much on the support side since it does appear to be R&D hardware. My ultimate goal here is to get RPLIDAR to work with rvis so I thought I would attempt as asking here.

I have attempted to get RPLIDAR to talk to Linuxmint 17 system and an Ubuntu 14.04 system. And when I run:

$ roslaunch rplidar_ros view_rplidar.launch

Error, cannot bind to the specified serial port /dev/ttyUSB0.

And the GUI warns:

No tf data.  Actual error: Fixed Frame [laser] does not exist

I believe the problem is that the USB to UART driver is installed with root permissions because I get the same error when I run the rplidar example program:

$ ./ultra_simple /dev/ttyUSB0
Error, cannot bind to the specified serial port /dev/ttyUSB0.

But it runs correctly when I run the above command under root:

$ sudo  ./ultra_simple /dev/ttyUSB0
   theta: 151.48 Dist: 00124.75 Q: 10 
   theta: 152.72 Dist: 00126.00 Q: 10 
   theta: 153.95 Dist: 00127.00 Q: 10 
   theta: 155.19 Dist: 00128.00 Q: 11 
   theta: 156.41 Dist: 00130.00 Q: 11 
   theta: 157.64 Dist: 00132.25 Q: 10 
   theta: 158.88 Dist: 00134.00 Q: 11 
   theta: 160.11 Dist: 00137.50 Q: 10 
   theta: 161.33 Dist: 00141.00 Q: 10

Is there way to install the driver without root permissions? Below is how I installed the driver:

$ cd Linux_3.x.x_VCP_Driver_Source
~/Linux_3.x.x_VCP_Driver_Source$ make
~/Linux_3.x.x_VCP_Driver_Source$ sudo cp cp210x.ko /lib/modules/3.13.0-43-generic/kernel/drivers/usb/serial/usbserial.ko
~/Linux_3.x.x_VCP_Driver_Source$ sudo insmod /lib/modules/3.13.0-43-generic/kernel/drivers/usb/serial/usbserial.ko
$insmod: ERROR: could not insert module /lib/modules/3.13.0-43-generic/kernel/drivers/usb/serial/usbserial.ko: File exists
$sudo insmod cp210x.ko

Can I do a simple chmod? Or is there a way to run ROS as root? When I run it with sudo it get 'command not found':

/catkin_ws$ sudo roslaunch rplidar_ros view_rplidar.launch
sudo: roslaunch: command not found

Thanks!