Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

UTM-30LX strange readings

Hi all,

I have recently installed a UTM-30LX hokuyo laser scanner on my pioneer. Everything worked good except that I have noticed something strange with the measurements of the laser while visualising the /scan topic on rviz.

As you can see in the pic when an object is in-front of a wall ( at various angles/distances) there are some false measurements and basically is like ROS is thinking is one continuous object by getting some false readings between the end of the object and the wall (where it should be empty space). This is happening regardless of the material of the object or the wall. In the pic case, the wall is wood and the object is cardboard.

image description

I have tried both hokuyo_node and urg_node with a variety of settings, included the ones that are suggested and tested to work for utm-30lx. Unfortunately the robot is unable to navigate like that because the cost map thinks is an obstacle there.

Does anyone have an idea why this is happening?