Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Moveit cannot load planning library when roscore is running on remote (non-localhost) pc

I am trying to get moveit working for Barrett-WAM. WAM has an internal pc which is running wam_node. I have a driver that publishes on wam_node topics from an external PC on the same network via LAN. Driver works perfectly. I can control the arm from an external PC via LAN. I think that means all the settings are correct. settings on external PC: ROS_IP=127.0.0.1 ROS_HOSTNAME=127.0.0.1 ROS_MASTER_URI=192.168.111.101 and in /etc/hosts I have an entry " 192.168.111.101 WAM"

I have never required to change any settings on WAM (internal PC) to send messages to wam_node via LAN.

But when I run the following command on external PC roslaunch wam_moveit_config demo.launch

This is the Output: (Partial)

and

and

Moveit.rviz says: NO PLANNING LIBRARY LOADED

Does moveit work on network ? Am I missing something ?

Thanks in advance.

Moveit cannot load planning library when roscore is running on remote (non-localhost) pc

I am trying to get moveit working for Barrett-WAM. WAM has an internal pc which is running wam_node. I have a driver that publishes on wam_node topics from an external PC on the same network via LAN. Driver works perfectly. I can control the arm from an external PC via LAN. I think that means all the settings are correct. settings on external PC: ROS_IP=127.0.0.1 ROS_HOSTNAME=127.0.0.1 ROS_MASTER_URI=192.168.111.101 and in /etc/hosts I have an entry " 192.168.111.101 WAM"

I have never required to change any settings on WAM (internal PC) to send messages to wam_node via LAN.

But when I run the following command on external PC roslaunch wam_moveit_config demo.launch

This is the Output: (Partial)

and

and

Moveit.rviz says: NO PLANNING LIBRARY LOADED

Does moveit work on network ? Am I missing something ?

Thanks in advance.

Moveit cannot load planning library when roscore is running on remote (non-localhost) pc

I am trying to get moveit working for Barrett-WAM. WAM has an internal pc which is running wam_node. I have a driver that publishes on wam_node topics from an external PC on the same network via LAN. Driver works perfectly. I can control the arm from an external PC via LAN. I think that means all the settings are correct. settings on external PC: ROS_IP=127.0.0.1 ROS_HOSTNAME=127.0.0.1 ROS_MASTER_URI=192.168.111.101 and in /etc/hosts I have an entry " 192.168.111.101 WAM"

I have never required to change any settings on WAM (internal PC) to send messages to wam_node via LAN.

But when I run the following command on external PC roslaunch wam_moveit_config demo.launch

This is the Output: (Partial)

[ERROR] [1403555647.510816509]: The kinematics plugin (arm) failed to load. Error: According to the loaded plugin descriptions the class wam_arm_kinematics/IKFastKinematicsPlugin with base class type kinematics::KinematicsBase does not exist. Declared types are  kdl_kinematics_plugin/KDLKinematicsPlugin pr2_arm_kinematics/PR2ArmKinematicsPlugin

and

and

[ERROR] [1403555690.896934602]: Unable to connect to action server within allotted time

and Moveit.rviz says: says:

NO PLANNING LIBRARY LOADED

LOADED

Does moveit work on network ? Am I missing something ?

Thanks in advance.