Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to use gscam with ar_pose?

Hi, I'm new to ROS and I'm trying to use ar_pose live tracking with webcam in the laptop (using gscam). But I'm not receiving any image in rviz. This is the error I receive in the terminal

ERROR: cannot launch node of type [ar_pose/ar_single]: can't locate node [ar_single] in package [ar_pose] Processing... [rviz-1] process has died [pid 10906, exit code -11, cmd /opt/ros/hydro/lib/rviz/rviz -d /home/gautham/hydro_workspace/sandbox/src/ar_tools/ar_pose/launch/live_single.rviz __name:=rviz __log:=/home/gautham/.ros/log/8edb2bfe-fb8f-11e3-8219-b13485d129c0/rviz-1.log].

This is my launch file <launch> <node pkg="rviz" type="rviz" name="rviz" args="-d $(find ar_pose)/launch/live_single.rviz"/> <node pkg="tf" type="static_transform_publisher" name="world_to_cam" args="0 0 0.5 -1.57 0 -1.57 world camera 10"/> <node ns="camera/gscam" pkg="image_proc" type="image_proc" name="image_proc"/> <node ns="camera" pkg="gscam" type="gscam" name="gscam" respawn="false" output="screen"> </node> <node name="ar_pose" pkg="ar_pose" type="ar_single" respawn="false" output="screen"> </node> </launch>

And in the rviz file:
Image Topic: camera/gscam/image_raw

Any help is appreciated. Thanks in advance :)

click to hide/show revision 2
No.2 Revision

How to use gscam with ar_pose?

Hi, I'm new to ROS and I'm trying to use ar_pose live tracking with webcam in the laptop (using gscam). But I'm not receiving any image in rviz. This is the error I receive in the terminal

[ERROR] [1403618585.907565185]: No camera_parameters.txt file found.  Use default file if no other is available.
ERROR: cannot launch node of type [ar_pose/ar_single]: can't locate node [ar_single] in package [ar_pose]
Processing...
[rviz-1] process has died [pid 10906, exit code -11, cmd /opt/ros/hydro/lib/rviz/rviz -d /home/gautham/hydro_workspace/sandbox/src/ar_tools/ar_pose/launch/live_single.rviz __name:=rviz __log:=/home/gautham/.ros/log/8edb2bfe-fb8f-11e3-8219-b13485d129c0/rviz-1.log].

__log:=/home/gautham/.ros/log/8edb2bfe-fb8f-11e3-8219-b13485d129c0/rviz-1.log].

This is my launch file file

<launch>
  <node pkg="rviz" type="rviz" name="rviz"  args="-d $(find ar_pose)/launch/live_single.rviz"/>
  <node pkg="tf" type="static_transform_publisher" name="world_to_cam"  args="0 0 0.5 -1.57 0 -1.57 world camera 10"/>
10" />
  <node ns="camera/gscam" pkg="image_proc" type="image_proc" name="image_proc"/>
  <node ns="camera" pkg="gscam" type="gscam" name="gscam" name="gscam"
    respawn="false" output="screen">
          <param name="width" type="int" value="320" />
    <param name="height" type="int" value="240" />
    <param name="fps" type="int" value="30" />
    <param name="frame" type="string" value="camera" />
    <param name="device" type="string" value="/dev/video0" />
    <param name="camera_info_url" type="string"
      value="camera/gscam/camera_info" />
  </node>
  <node name="ar_pose" pkg="ar_pose" type="ar_single" respawn="false" respawn="false"
    output="screen">
          <param name="marker_pattern" type="string"
      value="$(find ar_pose)/data/4x4/4x4_1.patt"/>
    <param name="marker_width" type="double" value="152.4"/>
    <param name="marker_center_x" type="double" value="0.0"/>
    <param name="marker_center_y" type="double" value="0.0"/>
    <param name="threshold" type="int" value="100"/>
    <param name="use_history" type="bool" value="true"/>
  </node>
</launch>

</launch>

And in the rviz file:
Image Topic: camera/gscam/image_raw

Any help is appreciated. Thanks in advance :)