Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Strange error when using a new Hokuyo sensor-- Installation error

Dear All,

I am having this strange error message when I tried to use another Hokuyo Sensor (UHG-08LX), the range of this sensor is 8m and FOV of 270 degrees, with frequency of 30 Hz (Specifications of UHG-08LX). I replaced this with Hokuyo URG-04LX for mapping. I am using ROS fuerte, Ubuntu 12.04. I did checked whether the device is properly connected. I did the tutorial before operating referring the link here http://wiki.ros.org/hokuyo_node/Tutorials/UsingTheHokuyoNode

But every time I run hokuyo.launch file I get this error message after it subscribe to the hokuyo messages:

[ WARN] [1356005675.931956581]: The use_rep_117 parameter has not been specified and has been automatically set to true.  This parameter will be removed in Hydromedusa.  Please see: http://ros.org/wiki/rep_117/migration.
 [ERROR] [1356005680.166530146]: Exception thrown while opening Hokuyo.timeout reached (in hokuyo::laser::laserReadline) You may find further details at http://www.ros.org/wiki/hokuyo_node/Troubleshooting

Also, when using another hokuyo sensor (Hokuyo UBG-04LX-F01- Rapid), the same message appears. Both sensors have a high frequency rate.

What could be the problem. Does ROS does not allow new hokuyo sensors to be connected. Or do I have to register the new device everytime I use them. Please help me with this. I am planning to use a better sensor for mapping. I have no problems using the hokuyo 04LX sensor so far.

Thank you