Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Problem with Hokuyo UTM-30LX-EW.

Hi, I want use a laser Hokuyo UTM-30LX-EW in ROS Hydro and Ubuntu 12.04. This laser, uses ethernet connection. I tried urg_node link text and urgwidget-wrapper, but when I connect the laser and run my launch file, I have this error:

[ERROR] [1393842815.953332067]: Error connecting to Hokuyo: Could not open network Hokuyo: 192.168.0.10:10940 could not open ethernet port.

This is my launch file:

<launch>
  <node pkg="urg_node" type="urg_node" name="urg_node" output="screen">
    <rosparam>
      publish_intensity: false
      angle_min: -2.2689 
      angle_max: 2.2689 
      cluster: 1
      skip: 0
      ip_address: 192.168.0.10
      ip_port: 10940
      serial_port: /dev/ttyACM0
      frame_id: laser
      calibrate_time: true
      time_offset: 0.0
      publish_multiecho: false

    </rosparam>   
  </node>
</launch>

I edited my Ubuntu connection:

IP Address 192.168.0.10
Subnet Mask 255.255.255.0
Default Gateway 192.168.0.1

If I run ifconfig -a in Ubuntu:

eth0      Link encap:Ethernet  direcciónHW b4:99:ba:55:5e:2b  
          Direc. inet:192.168.0.10  Difus.:192.168.0.255  Másc:255.255.255.0
          Dirección inet6: fe80::b699:baff:fe55:5e2b/64 Alcance:Enlace
          ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:104042 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:52805 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000 
          Bytes RX:72906778 (72.9 MB)  TX bytes:7476887 (7.4 MB)
          Interrupción:20 Memoria:d4700000-d4720000 

eth1      Link encap:Ethernet  direcciónHW ec:55:f9:76:c8:cc  
          DIFUSIÓN MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:0 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:0 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000 
          Bytes RX:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupción:19 

lo        Link encap:Bucle local  
          Direc. inet:127.0.0.1  Másc:255.0.0.0
          Dirección inet6: ::1/128 Alcance:Anfitrión
          ACTIVO BUCLE FUNCIONANDO  MTU:16436  Métrica:1
          Paquetes RX:15538 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:15538 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:0 
          Bytes RX:1650762 (1.6 MB)  TX bytes:1650762 (1.6 MB)

I think that this problem is but the Ubuntu config, something problem with the port or similar, but I don´t know as resolve it. Thanks.

Problem with Hokuyo UTM-30LX-EW.

Hi, I want use a laser Hokuyo UTM-30LX-EW in ROS Hydro and Ubuntu 12.04. This laser, uses ethernet connection. I tried urg_node link text and urgwidget-wrapper, but when I connect the laser and run my launch file, I have this error:

[ERROR] [1393842815.953332067]: Error connecting to Hokuyo: Could not open network Hokuyo: 192.168.0.10:10940 could not open ethernet port.

This is my launch file:

<launch>
  <node pkg="urg_node" type="urg_node" name="urg_node" output="screen">
    <rosparam>
      publish_intensity: false
      angle_min: -2.2689 
      angle_max: 2.2689 
      cluster: 1
      skip: 0
      ip_address: 192.168.0.10
      ip_port: 10940
      serial_port: /dev/ttyACM0
      frame_id: laser
      calibrate_time: true
      time_offset: 0.0
      publish_multiecho: false

    </rosparam>   
  </node>
</launch>

I edited my Ubuntu connection:

IP Address 192.168.0.10
Subnet Mask 255.255.255.0
Default Gateway 192.168.0.1

If I run ifconfig -a in Ubuntu:

eth0      Link encap:Ethernet  direcciónHW b4:99:ba:55:5e:2b  
          Direc. inet:192.168.0.10  Difus.:192.168.0.255  Másc:255.255.255.0
          Dirección inet6: fe80::b699:baff:fe55:5e2b/64 Alcance:Enlace
          ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:104042 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:52805 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000 
          Bytes RX:72906778 (72.9 MB)  TX bytes:7476887 (7.4 MB)
          Interrupción:20 Memoria:d4700000-d4720000 

eth1      Link encap:Ethernet  direcciónHW ec:55:f9:76:c8:cc  
          DIFUSIÓN MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:0 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:0 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000 
          Bytes RX:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupción:19 

lo        Link encap:Bucle local  
          Direc. inet:127.0.0.1  Másc:255.0.0.0
          Dirección inet6: ::1/128 Alcance:Anfitrión
          ACTIVO BUCLE FUNCIONANDO  MTU:16436  Métrica:1
          Paquetes RX:15538 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:15538 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:0 
          Bytes RX:1650762 (1.6 MB)  TX bytes:1650762 (1.6 MB)

I think that this problem is but the Ubuntu config, something problem with the port or similar, but I don´t know as resolve it. Thanks.