Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

robot rviz tf

Hi,

I am new to ROS. I tryed to use the Pioneer 3-AT urdf model provided in the p2os-Master stack.If I have a frame tree for this robot, and want to show this robot in a fixed map, in Rviz, I would only have to broadcast its transform with parent link: static_map, for example, and child link: base_link and publish the joint states for the joints that are not fixed, if I have robot_state_publisher running. Is that correct?

I checked in the tf topic. All transforms are being published as expected, but in Rviz, when I put the static_map as fixed frame, it says there are only transforms for the base_link and the static_map. Do I need to broadcast all the transforms with the static_map as the parent link? I did one publisher priorly which I only broadcasted the transform for the static_map and published the joints that were not fixed, and that worked.

What should I do?

robot rviz tf

Hi,

I am new to ROS. I tryed to use the Pioneer 3-AT urdf model provided in the p2os-Master stack.If I have a frame tree for this robot, and want to show this robot in a fixed map, in Rviz, I would only have to broadcast its transform with parent link: static_map, for example, and child link: base_link and publish the joint states for the joints that are not fixed, if I have robot_state_publisher running. Is that correct?

I checked in the tf topic. All transforms are being published as expected, but in Rviz, when I put the static_map as fixed frame, it says there are only transforms for the base_link and the static_map. Do I need to broadcast all the transforms with the static_map as the parent link? I did one publisher priorly which I only broadcasted the transform for the static_map and published the joints that were not fixed, and that worked.

I had divided the nodes to be launched in 2 diferent launch files, when I tryed to launch then all in one launch file, in Rviz, it says there are tansforms for all, but only the transform for base_link is correct, all others stay on ground beneath the base_link frame.

What should I do?