Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Unable to send messages from the pc back to the node on Android phone.

Hi,

I have been using the android package ( http://www.ros.org/wiki/android ) which uses the SL4A scripting environment on the android phone to execute scripts. The package allows successful connection with the roscore running on the host pc.

The test node created by the package can publish onto topics and the computer can receive it. However, the package cannot receive messages which are published onto topics by the computer.

A look at the problem showed that if you ran a second script to create another test node that publishes onto the topic the first test node is subscribed to, the first test node responds correctly. Therefore, I guess it is the problem with the data not being transferred successfully back to the script.

Please advise on how I can possibly configure this.

Soe

Unable to send messages from the pc back to the node on Android phone.

Hi,

I have been using the android package ( http://www.ros.org/wiki/android ) which uses the SL4A scripting environment on the android phone to execute scripts. The package allows successful connection with the roscore running on the host pc.

The test node created by the package can publish onto topics and the computer can receive it. However, the package cannot receive messages which are published onto topics by the computer.

A look at the problem showed that if you ran a second script to create another test node that publishes onto the topic the first test node is subscribed to, the first test node responds correctly. Therefore, I guess it is the problem with the data not being transferred successfully back to the script.

Please advise on how I can possibly configure this.

Soe

Unable to send messages from the pc back to the node on Android phone.

Hi,

I have been using the android package ( http://www.ros.org/wiki/android ) which uses the SL4A scripting environment on the android phone to execute scripts. The package allows successful connection with the roscore running on the host pc.

The test node created by the package can publish onto topics and the computer can receive it. However, the package cannot receive messages which are published onto topics by the computer.

A look at the problem showed that if you ran a second script to create another test node that publishes onto the topic the first test node is subscribed to, the first test node responds correctly. Therefore, I guess it is the problem with the data not being transferred successfully back to the script.

Please advise on how I can possibly configure this.

Soe