Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

rviz is agonizingly slow

Hello,

Are there any common reasons that would cause RVIZ to update very very slowly? I've been working with the Xbox Kinect and depth point clouds and every time I start rviz with the openni_camera node (ie, $roslaunch openni_camera openni_node.launch, $rosrun rviz rviz as suggested from the http://www.ros.org/wiki/openni_camera guide), everything on Ubuntu slows way down. The point cloud updates maybe once every 30 seconds. Is it just a problem of the amount of data being passed from the Kinect to rviz? Or could it be that my Asus EeeBox PC doesn't have enough umph to handle the data? Or is there some mysterious setting on rviz that only the enlightened know about which makes rviz more useful as a real-time observation tool for what your robot is up to?

I've run through the rviz documentation and aside from changing a few settings using the dynamic_reconfigure gui I can't find any solutions. Advice, anyone? Do any of you pro ROS users have optimal system setting suggestions?

Thanks,

Khiya

rviz is agonizingly slow

Hello,

Are there any common reasons that would cause RVIZ to update very very slowly? I've been working with the Xbox Kinect and depth point clouds and every time I start rviz with the openni_camera node (ie, $roslaunch openni_camera openni_node.launch, $rosrun rviz rviz as suggested from the http://www.ros.org/wiki/openni_camera guide), everything on Ubuntu slows way down. The point cloud updates maybe once every 30 seconds. Is it just a problem of the amount of data being passed from the Kinect to rviz? Or could it be that my Asus EeeBox PC doesn't have enough umph to handle the data? Or is there some mysterious setting on rviz that only the enlightened know about which makes rviz more useful as a real-time observation tool for what your robot is up to?

I've run through the rviz documentation and aside from changing a few settings using the dynamic_reconfigure gui I can't find any solutions. Advice, anyone? Do any of you pro ROS users have optimal system setting suggestions?

Thanks,

Khiya

rviz is agonizingly slow

Hello,

Are there any common reasons that would cause RVIZ to update very very slowly? I've been working with the Xbox Kinect and depth point clouds and every time I start rviz with the openni_camera node (ie, $roslaunch openni_camera openni_node.launch, $rosrun rviz rviz as suggested from the http://www.ros.org/wiki/openni_camera guide), everything on Ubuntu slows way down. The point cloud updates maybe once every 30 seconds. Is it just a problem of the amount of data being passed from the Kinect to rviz? Or could it be that my Asus EeeBox PC doesn't have enough umph to handle the data? Or is there some mysterious setting on rviz that only the enlightened know about which makes rviz more useful as a real-time observation tool for what your robot is up to?

I've run through the rviz documentation and aside from changing a few settings using the dynamic_reconfigure gui I can't find any solutions. Advice, anyone? Do any of you pro ROS users have optimal system setting suggestions?

Thanks,

Khiya

rviz is agonizingly slow

Hello,

Are there any common reasons that would cause RVIZ to update very very slowly? I've been working with the Xbox Kinect and depth point clouds and every time I start rviz with the openni_camera node (ie, $roslaunch openni_camera openni_node.launch, $rosrun rviz rviz as suggested from the http://www.ros.org/wiki/openni_camera guide), everything on Ubuntu slows way down. The point cloud updates maybe once every 30 seconds. Is it just a problem of the amount of data being passed from the Kinect to rviz? Or could it be that my Asus EeeBox PC doesn't have enough umph to handle the data? Or is there some mysterious setting on rviz that only the enlightened know about which makes rviz more useful as a real-time observation tool for what your robot is up to?

I've run through the rviz documentation and aside from changing a few settings using the dynamic_reconfigure gui I can't find any solutions. Advice, anyone? Do any of you pro ROS users have optimal system setting suggestions?

Thanks,

Khiya

rviz is agonizingly slow

Hello,

Are there any common reasons that would cause RVIZ to update very very slowly? I've been working with the Xbox Kinect and depth point clouds and every time I start rviz with the openni_camera node (ie, $roslaunch openni_camera openni_node.launch, $rosrun rviz rviz as suggested from the http://www.ros.org/wiki/openni_camera guide), everything on Ubuntu slows way down. The point cloud updates maybe once every 30 seconds. Is it just a problem of the amount of data being passed from the Kinect to rviz? Or could it be that my Asus EeeBox PC doesn't have enough umph to handle the data? Or is there some mysterious setting on rviz that only the enlightened know about which makes rviz more useful as a real-time observation tool for what your robot is up to?

I've run through the rviz documentation and aside from changing a few settings using the dynamic_reconfigure gui I can't find any solutions. Advice, anyone? Do any of you pro ROS users have optimal system setting suggestions?

Thanks,

Khiya

rviz is agonizingly slow

Hello,

Are there any common reasons that would cause RVIZ to update very very slowly? I've been working with the Xbox Kinect and depth point clouds and every time I start rviz with the openni_camera node (ie, $roslaunch openni_camera openni_node.launch, $rosrun rviz rviz as suggested from the http://www.ros.org/wiki/openni_camera guide), everything on Ubuntu slows way down. The point cloud updates maybe once every 30 seconds. Is it just a problem of the amount of data being passed from the Kinect to rviz? Or could it be that my Asus EeeBox PC doesn't have enough umph to handle the data? Or is there some mysterious setting on rviz that only the enlightened know about which makes rviz more useful as a real-time observation tool for what your robot is up to?

I've run through the rviz documentation and aside from changing a few settings using the dynamic_reconfigure gui I can't find any solutions. Advice, anyone? Do any of you pro ROS users have optimal system setting suggestions?

Thanks,

Khiya