Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Help troubleshooting foreign relay

I believe I'm sending topic data over a foreign relay, but nothing comes out on the foreign machine

On machine1:

rostopic pub -r 10 /foo /std_msgs/String hello rosrun foreign_relay foreign_relay adv http://machine2/11311 /machine1/foo /foo rostopic echo /foo shows a parade of hellos, as you'd expect

on machine 2:

rostopic list shows /machine1/foo rostopic info /machine1/foo shows * /foo_foreign_relay_0_adv_1306438093482799609 (http://machine1:54200/)

but rostopic echo /machine1/foo is empty

roswtf on machine2 reports:

ERROR Could not contact the following nodes: * /foo_foreign_relay_0_adv_1306439078454201491

ERROR The following nodes should be connected but aren't: * /foo_foreign_relay_0_adv_1306439078454201491->/rostopic_16013_1306439118679 (/klaup/foo)

suggestions on debugging?

thanks.

Help troubleshooting foreign relay

I believe I'm sending topic data over a foreign relay, but nothing comes out on the foreign machine

On machine1:

rostopic pub -r 10 /foo /std_msgs/String hello rosrun foreign_relay foreign_relay adv http://machine2/11311 http://machine2:11311 /machine1/foo /foo rostopic echo /foo shows a parade of hellos, as you'd expect

on machine 2:

rostopic list shows /machine1/foo rostopic info /machine1/foo shows * /foo_foreign_relay_0_adv_1306438093482799609 (http://machine1:54200/)

but rostopic echo /machine1/foo is empty

roswtf on machine2 reports:

ERROR Could not contact the following nodes: * /foo_foreign_relay_0_adv_1306439078454201491

ERROR The following nodes should be connected but aren't: * /foo_foreign_relay_0_adv_1306439078454201491->/rostopic_16013_1306439118679 (/klaup/foo)(/machine1/foo)

suggestions on debugging?

thanks.

click to hide/show revision 3
No.3 Revision

Help troubleshooting foreign relay

I believe I'm sending topic data over a foreign relay, but nothing comes out on the foreign machine

On machine1:

rostopic pub -r 10 /foo /std_msgs/String hello hello

rosrun foreign_relay foreign_relay adv http://machine2:11311 /machine1/foo /foo /foo

rostopic echo /foo shows a parade of hellos, as you'd expect

on machine 2:

rostopic list shows /machine1/foo /machine1/foo

rostopic info /machine1/foo shows * /foo_foreign_relay_0_adv_1306438093482799609 (http://machine1:54200/)

but rostopic echo /machine1/foo is empty

roswtf on machine2 reports:

ERROR Could not contact the following nodes: * /foo_foreign_relay_0_adv_1306439078454201491

ERROR The following nodes should be connected but aren't: * /foo_foreign_relay_0_adv_1306439078454201491->/rostopic_16013_1306439118679 (/machine1/foo)

suggestions on debugging?

thanks.