Ask Your Question
0

Rviz problem after installing Hydro

asked 2013-11-10 23:18:37 -0600

Akshay_Bhardwaj_nsit gravatar image

updated 2013-11-14 10:12:46 -0600

tfoote gravatar image

I was unable to open some urdf files in rviz with errors like 'could not find stack/package' 'cannot load model'. To check if they are opening in MoveIt i installed ROS hydro. urdf file is still gave the same error. However, along with that i was unable to open urdf files (that worked fine with groovy initially) in both groovy and hydro. In hydro the error was same 'could not find stack/package' while in groovy it was

ERROR: the config file '/opt/ros/groovy/stacks/robot_model_tutorials/urdf_tutorial/urdf.vcg' is a .vcg file, which is the old rviz config format.
   New config files have a .rviz extension and use YAML formatting.  The format changed
   between Fuerte and Groovy.  There is not (yet) an automated conversion program.

Now, i have uninstalled hydro but groovy is giving same errors and my urdf files in rviz are still not opening. Please help.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-11-11 03:37:27 -0600

updated 2013-11-11 03:41:52 -0600

I believe that the Groovy error has nothing to do with the urdf files themselves. I'm guessing that you are calling a launch file that is opening rviz with the urdf.vcg file using the -d argument. This is throwing the error because rviz in groovy doesn't use vcg files anymore. On my system in /opt/ros/groovy/stacks/robot_model_tutorials/urdf_tutorial/ I have a urdf.vcg file, and a display.launch file that explicitly sets the urdf.vcg configuration. In /opt/ros/groovy/share/urdf_tutorial I have a display.launch file that instead uses a urdf.rviz file. This is the correct launch file, and it should work for you.

Right now, on Groovy, there are two apt-get packages that both wrap up the files I've been talking about. ros-groovy-urdf-tutorial provides the correct display.launch file, and ros-groovy-robot-model-tutorials provides the one that you are trying to call. To call the correct display.launch, check that you have the urdf-tutorial package installed.

Alternatively, you could just copy the launch file and comment or edit the calls to rviz. If you are using your own launch file, then you probably just need to edit it a bit.

edit flag offensive delete link more
0

answered 2013-11-11 08:31:51 -0600

Akshay_Bhardwaj_nsit gravatar image

Problem solved. I actually overlaid the catkin workspace (using its catkin tutorials on ros website)on the top of existing one and then sourced it. Then opened my urdf file in rviz and everything went fine. However, i still don't fully comprehend the solution. #Jarvis I couldn't implement your solution but I think this would have also done the job. Thanks a lot for helping.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-10 23:18:37 -0600

Seen: 1,034 times

Last updated: Nov 11 '13