Ask Your Question
0

Unmet Dependencies on Lubuntu 13.10 Desktop

asked 2013-11-08 15:03:10 -0500

altemir gravatar image

updated 2013-11-09 02:40:52 -0500

I'm a newbie to ROS and Linux. I have Lubuntu 13.10 installed on my laptop and I want to install ROS. When I go to install ROS (Precise version), I get "unmet dependencies" and the install fails.

Should I be installing ROS on Lubuntu in the first place? This is an old laptop so I wanted as thin a version of Ubuntu as possible and I believe that Lubuntu 13.10 (Saucy Salamander) has the same core as Ubuntu 12.04 (Precise).

Am I headed in the right direction? How can I resolve these "unmet dependencies"? I believe the "sudo apt-get update" was successful.

Incidentally, these are the unmet dependencies I'm getting:

The following packages have unmet dependencies:
 ros-hydro-desktop-full : Depends: ros-hydro-desktop but it is not going to be installed
                          Depends: ros-hydro-mobile but it is not going to be installed
                          Depends: ros-hydro-perception but it is not going to be installed
                          Depends: ros-hydro-simulators but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-11-10 05:20:51 -0500

altemir gravatar image

I figured it out ... As I now realize, Lubuntu 13.10 does not use the Ubuntu 12.04 core. It uses the 13.10 core. duh. All I did was to reinstall Lubuntu, this time using the older 12.04 version, which is what ROS Hydro needs to work. Installation went fine and it seems to be working.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-08 15:03:10 -0500

Seen: 662 times

Last updated: Nov 10 '13