Ask Your Question
2

Ros Mutiple Machine

asked 2011-05-06 20:13:42 -0600

embeddedheaven gravatar image

updated 2016-10-24 09:03:29 -0600

ngrennan gravatar image

Dear all,

I have to machine client and server.In client pc I have kinect, and I set the ROS_MASTER_URI = server ip.

When I run rviz in clien pc i got the image and pointclouds, but when i try to run rviz in master pc I can't get anything :(

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2011-05-09 19:05:41 -0600

embeddedheaven gravatar image

Thanks you I got it run well now, with you setting and disable firewall in both computer

sudo ufw disable
edit flag offensive delete link more
4

answered 2011-05-08 01:20:47 -0600

Daniel Stonier gravatar image

Problems occur when you have multiple network interfaces on your computers or hostnames are getting confused. To be safe I always set the triple on both master and client computers.

Master (192.168.1.100):

export ROS_MASTER_URI=http://localhost:11311
export ROS_HOSTNAME=192.168.1.100
export ROS_IP=192.168.1.100

Client (192.168.1.101)

export ROS_MASTER_URI=http://192.168.1.100:11311
export ROS_HOSTNAME=192.168.1.101
export ROS_IP=192.168.1.101

I also seem to have trouble with virtualbox nat, but bridged networking works fine. Other sources of information:

Also see patrick's link to a similar ros answer.

edit flag offensive delete link more

Comments

Thanks a lot. that solved my issue.

Haresh Karnan gravatar imageHaresh Karnan ( 2018-04-10 12:20:18 -0600 )edit
3

answered 2011-05-07 06:42:14 -0600

mjcarroll gravatar image

In addition to the ROS_MASTER_URI environment variable, you may also want to set ROS_HOSTNAME and ROS_IP.

For example:

export ROS_HOSTNAME=192.168.0.21                                                     
export ROS_IP=192.168.0.21                                                           
export ROS_MASTER_URI=http://192.168.0.21:11311
edit flag offensive delete link more

Comments

+1. Also, you might find this question and its answers useful: http://answers.ros.org/question/647/nodes-with-2-computers.
Patrick Bouffard gravatar imagePatrick Bouffard ( 2011-05-07 08:42:12 -0600 )edit
Might want to check that, it would be correct for the master computer settings, but not the client (ROS_IP and ROS_HOSTNAME should be the client ip, not the master ip).
Daniel Stonier gravatar imageDaniel Stonier ( 2011-05-08 01:21:27 -0600 )edit
1

answered 2011-05-06 20:19:43 -0600

Murph gravatar image

I solved my connectivity issues by playing with the 'rosnode' command. It lets you view and ping the other ros nodes that you may be connected to. In my case, I discovered that one of my nodes wasn't setup right so the connections would get blocked.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-05-06 20:13:42 -0600

Seen: 2,086 times

Last updated: May 09 '11