Ask Your Question
1

ros_package_path

asked 2011-04-19 02:28:20 -0500

soetommy gravatar image

updated 2014-01-28 17:09:33 -0500

ngrennan gravatar image

Hi,

Can you tell me the default ROS_PACKAGE_PATH please?

Also, is the faulty ROS_PACKAGE_PATH the reason why I continue receiving the error "No arguments could be parsed into valid package or stack names" while I'm trying to install the joy package?

Thank you!

Soe

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-04-19 14:55:00 -0500

tfoote gravatar image

ROS_PACKAGE_PATH is documented on the wiki here

The first few beginner tutorials walk you through how to manage your path.

edit flag offensive delete link more
3

answered 2011-04-19 02:35:31 -0500

Murph gravatar image

There is no specific 'default ROS_PACKAGE_PATH'. It would depend on your distribution and method of installing ROS. On my ubuntu machine, it is /opt/ros/diamondback/stacks

You might try running 'locate setup.bash' (or zsh) to find your ros installation if you do not know where it it. Sourcing that file ('source setup.bash') should set the appropriate package path for that ros installation.

edit flag offensive delete link more

Comments

Hi Murph, Thanks for the suggestion. When I tried "locate setup.bash", it returns "/opt/ros/diamondback/stacks/simulator_gazebo/gazebo/setup.bash". Is it working correctly? Also, can you also explain me on the second part of the previous question: Why do it keep stating "No arguments could be parsed into valid package or stack names" while I'm trying to install the joy package? Soe
soetommy gravatar imagesoetommy ( 2011-04-19 03:28:15 -0500 )edit
Does it also have /opt/ros/diamondback/setup.bash? That file should be there, I'd think (the gazebo one isn't too important). The arguments can't be parsed part could be because your ROS_PACKAGE_PATH is set wrong, or because you've got the install command wrong. What command are you running?
Murph gravatar imageMurph ( 2011-04-19 03:46:38 -0500 )edit
sorry for the confusion, I've removed setup.bash from gazebo in trunk. They will not be there in the next release.
hsu gravatar imagehsu ( 2011-04-25 16:30:48 -0500 )edit
0

answered 2011-04-20 02:59:34 -0500

tyleroar gravatar image

On my install, ROS_PACKAGE_PATH is set at the very bottom of /root/.bashrc. For CTurtle it is set to /opt/ros/csturtle/stacks.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-04-19 02:28:20 -0500

Seen: 1,401 times

Last updated: Apr 20 '11