Ask Your Question
1

Moveit! and rviz interactive markers problem [closed]

asked 2013-10-29 05:50:30 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello dear Community! Could someone help me with the problem I'm experiencing with Interactive Moveit! markers in rviz with my simple test robot arm. Please review the link www.youtube.com/watch?v=M1c8A-DfghA and tell me please why I can't change the Goal State with the Interactive Marker? And as you would see from video I can do this through the Planning Tab, setting the random Goal State. What should I do to force Interactive Marker to change the Goal State? Please help me with this stopper.

Please feel free to ask from me (I do really want find the problem) all that is necessary to help to resolve this problem. I have successfully used pr2_moveit_config tutorial, and Interactive Markers for move groups (like right_arm) out there works fine.

Thanks, Alexey!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-10-15 17:13:51.867736

5 Answers

Sort by » oldest newest most voted
0

answered 2015-10-17 07:40:02 -0600

donmrsir gravatar image

The problem is that having an arm with less than 6DOF, dont allow you to control your arm in position and orientation (since you dont have enough DOF to do that), so the motion planner fails. Then in this situation if you want to have a correct control you have to set an "only position planner".

edit flag offensive delete link more
2

answered 2013-10-29 22:52:33 -0600

isucan gravatar image

To me it looks like the IK solver always fails to find a solution. Is your arm < 6DOF? Can you try to check the Approximate IK checkbox in the first tab?

edit flag offensive delete link more
0

answered 2013-10-30 01:45:41 -0600

maska gravatar image

According to the DOF formula m = 3*(n - 1) - 2*f I would say this test arm is 4 DOF. All four are managed with the Joint Stabe Publisher GUI panel. Also I've checked the Allow Approximate IK Solutions checkbox. You can see how it works in the latest video www.youtube.com/watch?v=GUY_H8WcKCI I have tried this before (it was in the first video in this thread) and this fits to what it should be to some degree but it is very inconvenient. But I want to understand what really the issue is and how to elemiate the problem in future. I can post whatever files are need for revision. Only tell me where do you prefer me to host them.

edit flag offensive delete link more
0

answered 2013-10-30 03:41:53 -0600

maska gravatar image

And this code doesn't work as well in my move_group sample code I'm trying to use with this test arm group.setRandomTarget(); //this really sets the Random Target (I know that it is FK) group.setStartStateToCurrentState(); // this function doesn't set the Start State to the newly randomly created

edit flag offensive delete link more

Comments

I've found that URDF Exporter for SolidWorks has incorrectly selected joint types. Continuous instead of revolute. Trying to fix...

maska gravatar imagemaska ( 2013-11-01 03:19:27 -0600 )edit

Changed to correct "revolute" type but it doesn't help. Looks like the problem is in axis orientation. Is there any conventions for how the joint axes should be oriented relatively each other?

maska gravatar imagemaska ( 2013-11-04 03:32:35 -0600 )edit
1

I have set the position_only_ik: True in kinematics.yaml file and this has solved the problem.

maska gravatar imagemaska ( 2013-11-07 10:55:14 -0600 )edit

Could you elaborate a little bit more about this? I also had the same problem and once I checked the "allow approximate IK solution" my RVIZ simulation worked fine. But are you saying that this option is not the correct way of controlling the RVIZ arm? Also what did you mean by "set the position_only_ik: True in kinematics.yaml file"? I looked through my .yaml file and did not see parameter like the one you mentioned. Any help would greatly be appreciated.

mfran89 gravatar imagemfran89 ( 2014-01-17 06:28:18 -0600 )edit
1

By the way the "set the position_only_ik" param is not in your .yml by default. So you just have to add the line "set the position_only_ik: True" in your kinematics.yaml file in each of thre groups you want to do the planning this way.

donmrsir gravatar imagedonmrsir ( 2015-10-17 07:43:01 -0600 )edit

Hi @maska! thank you for your replies, it work for my 3 DOF Arm!! One week stuck and it was so easy but frustrating, just because I could also move the robot in RViz and with the random position.

Thank you very much!!

jdeleon gravatar imagejdeleon ( 2018-10-02 10:27:30 -0600 )edit
-2

answered 2013-10-29 11:48:42 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Did somebody at least seen the video that I've uploaded?

edit flag offensive delete link more

Comments

1

I have, yes

isucan gravatar imageisucan ( 2013-10-29 22:51:40 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2013-10-29 05:50:30 -0600

Seen: 1,212 times

Last updated: Oct 29 '13