Ask Your Question
2

Should i be able to set the current pose for amcl?

asked 2011-03-23 04:51:25 -0500

Murph gravatar image

updated 2011-03-23 05:01:48 -0500

tfoote gravatar image

In rviz i can click '2d pose estimate' and it'll say: or something. But it won't actually move the estimates that amcl is providing.

Additionally, i don't see a published service or subscribed topic for this in amcl beyond the 'initial' pose. Do i need to change the initial pose and somehow restart amcl?

edit retag flag offensive close merge delete

Comments

Also, additionally, should I be able to *see* the current pose? rviz suppose 'pose' but not 'PoseWithCovarianceStamped' that amcl outputs.
Murph gravatar imageMurph ( 2011-03-23 05:27:53 -0500 )edit
What is your "fixed frame" set to when you do the 2D pose estimate? What topic is set for the "initialpose" topic in rviz?
Eric Perko gravatar imageEric Perko ( 2011-03-23 11:11:39 -0500 )edit
Fixed frame is set to /odom currently.
Murph gravatar imageMurph ( 2011-03-28 04:43:31 -0500 )edit
and the 2d pose esstimate topic is set to "initialpose"
Murph gravatar imageMurph ( 2011-03-28 04:44:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
6

answered 2011-03-28 05:12:40 -0500

Eric Perko gravatar image

In order for rviz to correctly set the initialpose for AMCL, rviz's fixed frame must be the same as AMCL's map frame.

Change your fixed frame in rviz to /map and then your 2D Pose Estimates should work. You can verify that it is working by subscribing to the PoseArray particle cloud output by AMCL - after a successful estimate, a cloud of particles will be centered on the location you indicated.

edit flag offensive delete link more

Comments

The cloud of particles does not seem to change location when i do a 2D pose estimate in rviz. I have the fixed frame on /map.
Murph gravatar imageMurph ( 2011-03-28 06:45:54 -0500 )edit
Ugh. Seems that my network connection was suspect (I guess the master node couldn't ping the rviz node). -_- your answer was right. thanks!
Murph gravatar imageMurph ( 2011-03-28 08:35:37 -0500 )edit

Thank you! Running rviz on the same machine as the master fixed it for me!

ounsworth gravatar imageounsworth ( 2014-06-17 20:35:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-23 04:51:25 -0500

Seen: 1,711 times

Last updated: Mar 28 '11