diagnostics broken dependencies for laser-driver in ARM install [closed]

asked 2013-10-26 08:43:59 -0500

dan gravatar image

updated 2014-01-28 17:18:21 -0500

ngrennan gravatar image

I am trying to install groovy on an ODROID-U2. Followed the wiki instructions for ARM installation and that worked fine, roscore runs. Now I am adding packages to get the nav stack working with a hokoyu laser rangefinder. The hokuyo_node is in laser-drivers, but sudo apt-get install ros-groovy-laser-drivers fails with the following message:

The following packages have unmet dependencies: ros-groovy-laser-drivers : Depends: ros-groovy-diagnostics (= 1.7.10-0precise-20130331-0640-+0000) but 1.7.10-0precise-20130430-1620-+0000 is to be installed

I apt-get installed ros-groovy-diagnostics earlier and am assuming that in some way the diagnostics package from the ARM build differs from the standard build, but have no idea how to fix this.

I tried removing ros-groovy-diagnostics just to see how that changes the error message and, when trying sudo apt-get install ros-groovy-laser-drivers, now the message is:

Depends: ros-groovy-diagnostics (= 1.7.10-0precise-20130331-0640-+0000) but it is not going to be installed

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by dan
close date 2015-09-02 21:56:59.887437