lib_rgbdtools failed

asked 2013-10-22 18:34:34 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am trying to install ccny_rgdb_tools following this instruction: github.com/ccny-ros-pkg/ccny_rgbd_tools

when i rosmake ccny_rgbd_tools , it failed, i tried sudo apt-get remove ros-groovy-libg2o but nothing changed :( I found that the error occurs from lib_rgbdtools This is my

buildfailures-with-context.txt

Build failures with context:

lib_rgbdtools mkdir -p rgbdtools_git/build cd rgbdtools_git/build && cmake ../ -DCMAKE_INSTALL_PREFIX=/home/bigboy/ccny_rgbd_tools/lib_rgbdtools -- checking for module 'openni-dev' -- package 'openni-dev' not found -- Could NOT find openni (missing: OPENNI_INCLUDE_DIRS) * WARNING * io features related to openni will be disabled -- checking for module 'openni-dev' -- package 'openni-dev' not found -- Could NOT find openni (missing: OPENNI_INCLUDE_DIRS) * WARNING * visualization features related to openni will be disabled -- looking for PCL_COMMON -- looking for PCL_KDTREE -- looking for PCL_OCTREE -- looking for PCL_SEARCH -- looking for PCL_SAMPLE_CONSENSUS -- looking for PCL_IO -- looking for PCL_GEOMETRY -- looking for PCL_FEATURES -- looking for PCL_FILTERS -- looking for PCL_KEYPOINTS -- looking for PCL_SURFACE -- looking for PCL_REGISTRATION -- looking for PCL_SEGMENTATION -- looking for PCL_VISUALIZATION -- looking for PCL_TRACKING -- Searching for g2o ... -- Found g2o headers in: /opt/ros/groovy/include/g2o -- Found libg2o: /opt/ros/groovy/lib/libg2o_core.so;/opt/ros/groovy/lib/libg2o_cli.so;/opt/ros/groovy/lib/libg2o_types_slam2d.so;/opt/ros/groovy/lib/libg2o_types_slam3d.so;/opt/ros/groovy/lib/libg2o_solver_csparse.so;/opt/ros/groovy/lib/libg2o_csparse_extension.so -- Configuring done -- Generating done -- Build files have been written to: /home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/build cd rgbdtools_git/build && make install make[1]: Entering directory /home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/build' make[2]: Entering directory/home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/build' make[3]: Entering directory /home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/build' make[3]: Leaving directory/home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/build' make[3]: Entering directory /home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/build' [ 6%] Building CXX object CMakeFiles/rgbdtools.dir/src/rgbd_frame.cpp.o /home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/src/rgbd_frame.cpp: In member function ‘void rgbdtools::RGBDFrame::constructFeaturePointCloud(rgbdtools::PointCloudFeature&)’: /home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/src/rgbd_frame.cpp:276:69: error: no match for ‘operator=’ in ‘cloud.pcl::PointCloud<pcl::PointXYZ>::header.std_msgs::Header_<std::allocator<void> >::stamp = (((double)((rgbdtools::RGBDFrame*)this)->rgbdtools::RGBDFrame::header.rgbdtools::Header::stamp.rgbdtools::Time::sec * 1.0e+6) + ((double)((rgbdtools::RGBDFrame*)this)->rgbdtools::RGBDFrame::header.rgbdtools::Header::stamp.rgbdtools::Time::nsec * 1.0000000000000000208166817117216851329430937767e-3))’ /home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/src/rgbd_frame.cpp:276:69: note: candidate is: /opt/ros/groovy/include/ros/time.h:169:22: note: ros::Time& ros::Time::operator=(const ros::Time&) /opt/ros/groovy/include/ros/time.h:169:22: note: no known conversion for argument 1 from ‘double’ to ‘const ros::Time&’ /home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/src/rgbd_frame.cpp: In member function ‘void rgbdtools::RGBDFrame::constructDensePointCloud(rgbdtools::PointCloudT&, double, double) const’: /home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/src/rgbd_frame.cpp:348:69: error: no match for ‘operator=’ in ‘cloud.pcl::PointCloud<pcl::PointXYZRGB>::header.std_msgs::Header_<std::allocator<void> >::stamp = (((double)((const rgbdtools::RGBDFrame*)this)->rgbdtools::RGBDFrame::header.rgbdtools::Header::stamp.rgbdtools::Time::sec * 1.0e+6) + ((double)((const rgbdtools::RGBDFrame*)this)->rgbdtools::RGBDFrame::header.rgbdtools::Header::stamp.rgbdtools::Time::nsec * 1.0000000000000000208166817117216851329430937767e-3))’ /home/bigboy/ccny_rgbd_tools/lib_rgbdtools/rgbdtools_git/src/rgbd_frame.cpp ... (more)

edit retag flag offensive close merge delete

Comments

1

I have the exact same problem... hope we get a answer soon. Good luck

sigmaduarte gravatar image sigmaduarte  ( 2013-10-24 07:20:39 -0600 )edit
3

Now I am very happy that the problem is solved: The solution is: Using the old version of this package. I used this https://github.com/ccny-ros-pkg/ccny_rgbd_tools/releases/tag/0.1.1 and everything works perfectly now. Goodluck :)

bigboy061293 gravatar image bigboy061293  ( 2013-10-24 07:29:15 -0600 )edit

Now I am very happy that the problem is solved: The solution is: Using the old version of this package. I used this https://github.com/ccny-ros-pkg/ccny_rgbd_tools/releases/tag/0.1.1 and everything works perfectly now. Goodluck :)

bigboy061293 gravatar image bigboy061293  ( 2013-10-24 07:29:28 -0600 )edit

So you just have to download and extract the file? do you change the name to ccny_rgbd_tools and erase the other one? Then use the comand rosmake ccny_rgbd_tools

sigmaduarte gravatar image sigmaduarte  ( 2013-10-24 07:54:28 -0600 )edit

I did exactly the same as the new one. Just download, extract, rename to ccny_rgbd_tools if you want, rosdep install ccny_rgbd_tools and rosmake ccny_rgbd_tools and enjoy the 3d mapping :)

bigboy061293 gravatar image bigboy061293  ( 2013-10-24 08:15:01 -0600 )edit

I did that, but instead of giving me the lib_rgbd error it now gets stuck on the ccny_g2o error. I then used the code line "sudo apt-get remove ros-groovy-libg2o" but nothing changed. Still not enjoying 3D mapping... hope we find a solution fast ;)

sigmaduarte gravatar image sigmaduarte  ( 2013-10-30 06:49:35 -0600 )edit

Same problem. How to solve this?

ZiyangLI gravatar image ZiyangLI  ( 2014-01-12 20:53:12 -0600 )edit

I ended up using SLAM instead of rgbd and it works really good

sigmaduarte gravatar image sigmaduarte  ( 2014-01-29 04:11:46 -0600 )edit